gnu: r-fields: Update to 11.4.
[jackhill/guix/guix.git] / gnu / packages / task-management.scm
index 340475c..601a361 100644 (file)
 (define-public taskwarrior
   (package
     (name "taskwarrior")
-    (version "2.4.3")
+    (version "2.5.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "http://taskwarrior.org/download/task-" version ".tar.gz"))
        (sha256 (base32
-                "1lkbw2fhshynbl7hppar1viapyrs712s14xhd8p3l8gyhvxbh0mv"))))
+                "059a9yc58wcicc6xxsjh1ph7k2yrag0spsahp1wqmsq6h7jwwyyq"))))
     (build-system cmake-build-system)
     (inputs
      `(("gnutls" ,gnutls)
        ("lua" ,lua)
-       ("util-linux" ,util-linux)))
+       ("util-linux" ,util-linux "lib")))
     (arguments
      `(#:tests? #f ; No tests implemented.
        #:phases
@@ -52,7 +52,7 @@
             (delete-file "src/cal")
             (delete-file "src/calendar")
             (delete-file "src/tw"))))))
-     (home-page "http://taskwarrior.org")
+     (home-page "https://taskwarrior.org")
     (synopsis "Command line task manager")
     (description
      "Taskwarrior is a command-line task manager following the Getting Things