gnu: moka-icon-theme: Add faba-icon-theme as propagated input.
[jackhill/guix/guix.git] / gnu / packages / gsasl.scm
index 3caeb1a..727d0f0 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,7 +22,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages libidn)
   #:use-module (gnu packages nettle)
-  #:use-module (gnu packages shishi)
+  #:use-module (gnu packages kerberos)
   #:use-module (gnu packages tls)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
 
 (define-public libntlm
   (package
-   (name "libntlm")
-   (version "1.3")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "http://www.nongnu.org/libntlm/releases/libntlm-" version
-                                ".tar.gz"))
-            (sha256 (base32
-                     "101pr110ardcj2di940g6vaqifsaxc44h6hjn81l63dvmkj5a6ga"))))
-   (build-system gnu-build-system)
-   (synopsis "Library that implements NTLM authentication")
-   (description
-    "Libntlm is a library that implements NTLM authentication")
-   (license license:lgpl2.1+)
-   (home-page "http://www.nongnu.org/libntlm/")))
+    (name "libntlm")
+    (version "1.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.nongnu.org/libntlm/releases/"
+                                  "libntlm-" version ".tar.gz"))
+              (sha256
+               (base32
+                "129532iiip2cjr5h03bgz184v64v27sfm1r70v3ms4yk65gdf5c4"))))
+    (build-system gnu-build-system)
+    (synopsis "Library that implements NTLM authentication")
+    (description
+     "Libntlm is a library that implements NTLM authentication.")
+    (license license:lgpl2.1+)
+    (home-page "http://www.nongnu.org/libntlm/")))
 
 (define-public gss
   (package
@@ -68,7 +70,7 @@ a generic, GSS interface, with which the calling application interacts via
 this library, freeing the application developer from needing to know about
 the underlying security implementation.")
    (license license:gpl3+)
-   (home-page "http://www.gnu.org/software/gss/")))
+   (home-page "https://www.gnu.org/software/gss/")))
 
 (define-public gsasl
   (package
@@ -96,4 +98,4 @@ Security Layer framework.  On network servers such as IMAP or SMTP servers,
 SASL is used to handle client/server authentication.  This package contains
 both a library and a command-line tool to access the library.")
    (license license:gpl3+)
-   (home-page "http://www.gnu.org/software/gsasl/")))
+   (home-page "https://www.gnu.org/software/gsasl/")))