gnu: julia: Update to 1.4.1.
[jackhill/guix/guix.git] / gnu / packages / abiword.scm
index 82a289e..9cfd12a 100644 (file)
@@ -1,5 +1,10 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages abiword)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages enchant)
 (define-public abiword
   (package
     (name "abiword")
-    (version "2.8.6")
+    (version "3.0.4")
     (source
       (origin
         (method url-fetch)
         (uri
-          (string-append "http://abisource.org/downloads/" name "/" version
-                         "/source/" name "-" version ".tar.gz"))
+          (string-append "https://www.abisource.com/downloads/abiword/" version
+                         "/source/abiword-" version ".tar.gz"))
         (sha256
-          (base32 "059sd2apxdmcacc4pll880i7vm18h0kyjsq299m1mz3c7ak8k46r"))
+         (base32 "1mx5l716n0z5788i19qmad30cck4v9ggr071cafw2nrf375rcc79"))
         (patches
-          (list
-            (search-patch "abiword-wmf-version-lookup-fix.patch")
-            (search-patch "abiword-no-include-glib-internal-headers.patch")
-            (search-patch "abiword-explictly-cast-bools.patch")
-            (search-patch "abiword-use-proper-png-api.patch")
-            (search-patch "abiword-pass-no-undefined-to-linker.patch")
-            (search-patch "abiword-link-plugins-against-backend.patch")))))
+         (search-patches "abiword-explictly-cast-bools.patch"))))
 
-    (build-system gnu-build-system)
+    (build-system glib-or-gtk-build-system)
     (arguments                   ;; NOTE: rsvg is disabled, since Abiword
       `(#:configure-flags        ;; supports it directly, and its BS is broken.
-        (list
+        (list                    ;; wmf was removed from Guix for security.
           "--enable-clipart"     ;; TODO: The following plugins have unresolved
           "--enable-templates"   ;; dependencies: aiksaurus, grammar, wpg, gda,
-          (string-append         ;; wordperfect, psion, mathview, goffice.
+          (string-append         ;; wordperfect, psion, mathview.
             "--enable-plugins="
               "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
-              "docbook " "eml " "freetranslation " "garble " "gdict " "gimp "
-              "google " "hancom " "hrtext " "iscii " "kword " "latex "
-              "loadbindings " "mht " "mif " "mswrite " "opendocument "
+              "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
+              "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
+              "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
               "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
               "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
-              "wikipedia " "wmf " "wml " "xslfo"))))
+              "wikipedia " "wml " "xslfo"))
+        ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
+        ;;                  assertion 'GDK_IS_SCREEN (screen)' failed
+        ;;                  GLib-GObject-CRITICAL **: g_object_get_qdata:
+        ;;                  assertion 'G_IS_OBJECT (object)' failed
+        ;; Manually starting the X server before the test phase did not help
+        ;; the tests to pass.
+        #:tests? #f
+        #:make-flags
+        (list "gtk_update_icon_cache=true")))
     (inputs
       `(("boost" ,boost)
         ("enchant" ,enchant)
         ("fontconfig" ,fontconfig)
         ("fribidi" ,fribidi)
         ("glib" ,glib)
-        ("gtk+" ,gtk+-2)
+        ("goffice" ,goffice)
+        ("gtk+" ,gtk+)
+        ("libchamplain" ,libchamplain)
         ("libglade" ,libglade)
         ("libgsf" ,libgsf)
-        ("libjpeg" ,libjpeg)
+        ("libjpeg" ,libjpeg-turbo)
         ("libpng" ,libpng)
         ("librsvg" ,librsvg)
-        ("libwmf" ,libwmf)
         ("libxml2" ,libxml2)
+        ("libxslt" ,libxslt)
         ("ots" ,ots)
         ("popt" ,popt)
         ("readline" ,readline)
+        ("telepathy" ,telepathy-glib)
         ("wv" ,wv)
         ("zlib" ,zlib)))
     (native-inputs
       `(("intltool" ,intltool)
         ("glib:bin" ,glib "bin")
+        ("libtool" ,libtool)
         ("pkg-config" ,pkg-config)))
-    (home-page "http://abisource.org/")
+    (home-page "https://www.abisource.com/")
     (synopsis "Word processing program")
-    (description
-      "AbiWord is a word processing program.  It is rapidly becoming a state
-of the art word processor, with lots of features useful for your daily work,
-personal needs, or for just some good old typing fun.")
+
+    ;; HACKERS: The comment below is here so that it shows up early in the
+    ;; .pot file.
+
+    ;; TRANSLATORS: Dear translator, We would like to inform you that package
+    ;; descriptions may occasionally include Texinfo markup.  Texinfo markup
+    ;; looks like "@code{rm -rf}", "@emph{important}", etc.  When translating,
+    ;; please leave markup as is.
+    (description "AbiWord is a word processing program.  It is rapidly
+becoming a state of the art word processor, with lots of features useful for
+your daily work, personal needs, or for just some good old typing fun.")
     (license license:gpl2+)))