gnu: dealii: Update to 8.5.0.
[jackhill/guix/guix.git] / gnu / packages / pretty-print.scm
index 8819b8a..9de2819 100644 (file)
@@ -2,6 +2,8 @@
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +24,7 @@
   #:use-module (guix packages)
   #:use-module (guix licenses)
   #:use-module (guix download)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages perl)
-  #:use-module (gnu packages pkg-config))
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages compression))
 
 (define-public a2ps
   (package
     (name "a2ps")
     (version "4.14")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/a2ps/a2ps-"
-                          version ".tar.gz"))
-      (sha256
-       (base32
-        "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))
-      (patches (search-patches
-                 "a2ps-CVE-2001-1593.patch"
-                 "a2ps-CVE-2014-0466.patch"))))
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/a2ps/a2ps-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Remove timestamp from the installed 'README' file.
+               '(substitute* "etc/README.in"
+                  (("@date@")
+                   "1st of some month, sometime after 1970")))
+              (patches (search-patches
+                        "a2ps-CVE-2001-1593.patch"
+                        "a2ps-CVE-2014-0466.patch"))))
     (build-system gnu-build-system)
     (inputs
      `(("psutils" ,psutils)
                             "tests/gps-ref/psmandup.ps")
                (("#! */bin/sh") (string-append
                                  "#!" (which "sh")))))))))
-    (home-page "http://www.gnu.org/software/a2ps")
+    (home-page "https://www.gnu.org/software/a2ps/")
     (synopsis "Any file to PostScript, including pretty-printing")
     (description
      "GNU a2ps converts almost anything to a PostScript file, ready for
@@ -117,7 +126,7 @@ special cases, such as pretty-printing \"--help\" output.")
     (arguments
      ;; Must define DIFF_CMD for tests to pass
      '(#:configure-flags '("CPPFLAGS=-DDIFF_CMD=\\\"diff\\\"")))
-    (home-page "http://www.gnu.org/software/trueprint")
+    (home-page "https://www.gnu.org/software/trueprint/")
     (synopsis "Pretty-print C sources and other plain text to PostScript")
     (description
      "GNU Trueprint translates C source code files as PostScript files.
@@ -138,7 +147,7 @@ indentation counting, function and file indices and more.")
        (base32
         "1fy0ymvzrrvs889zanxcaxjfcxarm2d3k43c9frmbl1ld7dblmkd"))))
     (build-system gnu-build-system)
-    (home-page "http://www.gnu.org/software/enscript")
+    (home-page "https://www.gnu.org/software/enscript/")
     (synopsis "Generating PostScript, including pretty-printing")
     (description
      "GNU Enscript is a program to convert ASCII text files to PostScript,
@@ -147,6 +156,30 @@ It also includes the capability to perform syntax highlighting for several
 different programming languages.")
     (license gpl3+)))
 
+(define-public fmt
+  (package
+    (name "fmt")
+    (version "3.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/fmtlib/fmt/releases/download/"
+                    version "/fmt-" version ".zip"))
+              (sha256
+               (base32
+                "0l4514mk83cjimynci3ghrfdchjy8cya1qa45c1fg2lsj7fg16jc"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (home-page "http://fmtlib.net/latest/")
+    (synopsis "Small and fast C++ formatting library")
+    (description
+     "@code{fmt} (formerly @code{cppformat}) is a formatting library for C++.
+It can be used as a safe alternative to @code{printf} or as a fast alternative
+to @code{IOStreams}.")
+    ;; The library is bsd-2, but documentation and tests include other licenses.
+    (license (list bsd-2 bsd-3 psfl))))
+
 (define-public source-highlight
   (package
     (name "source-highlight")
@@ -188,7 +221,7 @@ different programming languages.")
                                   "tests/test.tcl.html")
                      (("#! */bin/sh") "#!/bin/sh")))
                  %standard-phases)))
-    (home-page "http://www.gnu.org/software/src-highlite")
+    (home-page "https://www.gnu.org/software/src-highlite/")
     (synopsis "Produce a document with syntax highlighting from a source file")
     (description
      "GNU source-highlight reads in a source code file and produces an output