container: Gracefully report mount errors in the child process.
[jackhill/guix/guix.git] / gnu / packages / ed.scm
index 4a2d524..7cd1fcd 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages compression))
 
 (define-public ed
   (package
     (name "ed")
-    (version "1.9")
+    (version "1.12")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/ed/ed-"
-                                 version ".tar.gz"))
+                                 version ".tar.lz"))
              (sha256
               (base32
-               "122syihsx2hwzj75mkf5a9ssiky2xby748kp4cc00wzhmp7p5cym"))))
+               "0bw0187a311rci58vznvncsj6pfp8bhs5phrlrqn03sa2i1mfrfj"))))
     (build-system gnu-build-system)
+    (native-inputs `(("lzip" ,lzip)))
     (arguments
      '(#:configure-flags '("CC=gcc")
        #:phases (alist-cons-before 'patch-source-shebangs 'patch-test-suite
@@ -46,8 +48,8 @@
     (synopsis "Line-oriented text editor")
     (description
      "Ed is a line-oriented text editor: rather than offering an overview of
-a document, ed performs editing one line at a time.  It can be operated both
+a document, ed performs editing one line at a time.  It can be executed both
 interactively and via shell scripts.  Its method of command input allows
-complex tasks to be performed in an automated way, however it has largely
-been superceded by full-screen editors like Emacs or Moe.")
+complex tasks to be performed in an automated way.  GNU ed offers several
+extensions over the standard utility.")
     (license gpl3+)))