gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / idutils.scm
index 11dd6ea..63760c8 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +21,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (guix licenses)
+  #:use-module (gnu packages emacs)
   #:use-module (gnu packages))
 
 (define-public idutils
              (sha256
               (base32
                "1hmai3422iaqnp34kkzxdnywl7n7pvlxp11vrw66ybxn9wxg90c1"))
-             (patches (list
-                       (search-patch "diffutils-gets-undeclared.patch")))))
+             (patches (search-patches "diffutils-gets-undeclared.patch"))))
     (build-system gnu-build-system)
-    (inputs `(;; TODO: Add Emacs as an input for byte-compilation.
-              ;; ("emacs" ,emacs)
-              ))
+    (native-inputs `(("emacs" ,emacs-minimal)))
     (home-page "http://www.gnu.org/software/idutils/")
     (synopsis "Identifier database utilities")
     (description
-     "ID Utils provides tools to create an index if textual tokens used in a
-list of file names and to then query that index.  Thus, it allows the user
-to, for example, find all the uses of a particular function in all files of a
-large programming project.  In addition to handling textual tokens, it can
-also handle numeric constants and the contents of character strings.")
+     "The GNU idutils package includes tools to create an index of textual
+tokens used in a list of file names and then to query that index.  Thus, it
+allows the user to, for example, find all the uses of a particular function
+in a large programming project.  In addition to handling textual tokens, it
+can also handle numeric constants and the contents of character strings.")
     (license gpl3+)))