gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / gprolog.scm
index ad887cc..87c833e 100644 (file)
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages gprolog)
+  #:use-module (guix download)
   #:use-module (guix licenses)
   #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (srfi srfi-1))
 
 (define-public gprolog
   (package
         "13miyas47bmijmadm68cbvb21n4s156gjafz7kfx9brk9djfkh0q"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (alist-cons-before
+     `(#:configure-flags
+       (list (string-append
+              "--with-install-dir=" %output "/share/gprolog"))
+       #:phases (alist-cons-before
                  'configure 'change-dir-n-fix-shells
                  (lambda _
                    (chdir "src")
     (description
      "GNU Prolog is a standards-compliant Prolog compiler with constraint
 solving over finite domains.  It accepts Prolog+ constraint programs and
-produces a compiled, native binary which can function in a stand- alone
+produces a compiled, native binary which can function in a stand-alone
 manner.  It also features an interactive interpreter.")
-    (license (list gpl2+ lgpl3+))))
+    (license (list gpl2+ lgpl3+))
+
+    ;; See 'configure' for the list of supported architectures.
+    (supported-systems (fold delete
+                             %supported-systems
+                             '("armhf-linux" "mips64el-linux")))))