gnu: ccache: Update to 3.2.5.
[jackhill/guix/guix.git] / gnu / packages / unrtf.scm
index c98a1d7..162dec7 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix gexp)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages m4)
+  #:use-module (gnu packages base))
 
 (define-public unrtf
   (package
     (name "unrtf")
-    (version "0.19.7")
+    (version "0.21.9")
     (source (origin
              (method url-fetch)
-             (uri (string-append "mirror://gnu/unrtf/" version
-                                 "/unrtf-" version ".tar.gz"))
+             (uri (string-append "mirror://gnu/unrtf/unrtf-"
+                                 version ".tar.gz"))
              (sha256
               (base32
-               "1c15miv4ni395wix6qxiqgjfspd6ssdk1ly6mm8srh0jgpidgjzf"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:phases (alist-replace
-                 'configure
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   ;; No `configure' script; do it by hand.
-                   (let ((out (assoc-ref outputs "out")))
-                     (substitute* "Makefile"
-                       (("/usr/local") out))))
-                 %standard-phases)
+               "1pcdzf2h1prn393dkvg93v80vh38q0v817xnbwrlwxbdz4k7i8r2"))
+             (modules '((guix build utils)))
+             (snippet
+              #~(begin
+                  ;; The tarball includes site-specific generated files.
+                  ;; Remove them.
+                  (for-each delete-file '("config.log" "config.h"))
+                  (for-each delete-file
+                            (find-files "." "^Makefile$"))
+
+                  ;; The config/ directory contains dangling symlinks to
+                  ;; /usr/share/automake.
+                  (for-each delete-file (find-files "config"))
 
-       ;; There are test files, but apparently no automated test suite.
-       #:tests? #f))
+                  ;; Regenerate the whole thing.
+                  (setenv "PATH"
+                          (string-append #$autoconf "/bin:"
+                                         #$automake "/bin:"
+                                         #$m4 "/bin:"
+                                         #$grep "/bin:" #$sed "/bin:"
+                                         #$coreutils "/bin:"
+                                         (getenv "PATH")))
+                  (zero? (system* "autoreconf" "-vfi"))))))
+    (build-system gnu-build-system)
     (home-page "http://www.gnu.org/software/unrtf")
     (synopsis "Convert Rich Text Format documents to other formats")
     (description
-     "UnRTF is a program for converting text documents from RTF to HTML,
-LaTeX, or troff macros.  It supports changes in font characteristics,
-underlines and strikethroughs, superscripts and subscripts, and more.")
+     "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
+It supports changes in font characteristics, underlines and strikethroughs,
+superscripts and subscripts, and more.")
     (license gpl2+)))