Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / cpio.scm
index e9d9bd5..58b2f45 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,6 +20,7 @@
 (define-module (gnu packages cpio)
   #:use-module (guix licenses)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
 (define-public cpio
   (package
     (name "cpio")
-    (version "2.11")
+    (version "2.13")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/cpio/cpio-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1gavgpzqwgkpagjxw72xgxz52y1ifgz0ckqh8g7cckz7jvyhp0mv"))
-             (patches (list (search-patch "cpio-gets-undeclared.patch")))))
+               "0vbgnhkawdllgnkdn6zn1f56fczwk0518krakz2qbwhxmv2vvdga"))))
     (build-system gnu-build-system)
     (home-page "https://www.gnu.org/software/cpio/")
     (synopsis "Manage cpio and tar file archives")
     (description
-     "Cpio copies files into or out of cpio or tar archives.  In fact, many
-formats are supported, including legacy formats.  The format is determined
-automatically by the program and is handled appropriately. Furthermore, the
-location of the archive is not important.  It can be another file on the
-drive, a tape, or data on a pipe.")
+     "GNU cpio copies files into or out of cpio or tar archives.  Indeed,
+many formats are supported, including legacy formats.  The format is
+determined automatically by the program and is handled appropriately.
+Furthermore, the location of the archive is not important.  It can be another
+file on the drive, a tape, or data on a pipe.")
     (license gpl3+)))