gnu: Add emacs-slime.
[jackhill/guix/guix.git] / gnu / packages / icu4c.scm
index d5abb2c..d442b5e 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -18,7 +19,6 @@
 
 (define-module (gnu packages icu4c)
   #:use-module (gnu packages)
-  #:use-module (gnu packages patchelf)
   #:use-module (gnu packages perl)
   #:use-module (guix licenses)
   #:use-module (guix packages)
@@ -28,7 +28,7 @@
 (define-public icu4c
   (package
    (name "icu4c")
-   (version "50.1.1")
+   (version "55.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "http://download.icu-project.org/files/icu4c/"
                    "/icu4c-"
                    (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
                    "-src.tgz"))
-            (sha256 (base32
-                     "13yz0kk6zsgj94idnlr3vbg8iph5z4ly4b4xrd5wfja7q3ijdx56"))))
+            (sha256
+             (base32 "0ys5f5spizg45qlaa31j2lhgry0jka2gfha527n4ndfxxz5j4sz1"))
+            (patches (map search-patch '("icu4c-CVE-2014-6585.patch"
+                                         "icu4c-CVE-2015-1270.patch"
+                                         "icu4c-CVE-2015-4760.patch")))))
    (build-system gnu-build-system)
    (inputs
-    `(("patchelf" ,patchelf)
-      ("perl" ,perl)))
+    `(("perl" ,perl)))
    (arguments
-    `(#:modules ((guix build gnu-build-system)
-                 (guix build utils)
-                 (guix build rpath)
-                 (srfi srfi-26))
-      #:imported-modules ((guix build gnu-build-system)
-                          (guix build utils)
-                          (guix build rpath))
+    `(#:configure-flags
+      '("--enable-rpath"
+        ,@(if (string-prefix? "arm" (or (%current-target-system)
+                                        (%current-system)))
+              '("--with-data-packaging=archive")
+              '()))
       #:phases
-      (alist-replace
-       'unpack
-       (lambda* (#:key source #:allow-other-keys)
-        (and (zero? (system* "tar" "xvf" source))
-             (chdir "icu/source")))
-       (alist-replace
-        'configure
-        (lambda* (#:key #:allow-other-keys #:rest args)
-         (let ((configure (assoc-ref %standard-phases 'configure)))
-           ;; patch out two occurrences of /bin/sh from configure script
-           ;; that might have disappeared in a release later than 50.1.1
-           (substitute* "configure"
-             (("`/bin/sh")
-             (string-append "`" (which "bash"))))
-           (apply configure args)))
-       (alist-cons-after
-        'strip 'add-lib-to-runpath
-        (lambda* (#:key outputs #:allow-other-keys)
-          (let* ((out (assoc-ref outputs "out"))
-                 (lib (string-append out "/lib")))
-            ;; Add LIB to the RUNPATH of all the libraries.
-            (with-directory-excursion out
-              (for-each (cut augment-rpath <> lib)
-                        (find-files "lib" ".*")))))
-        %standard-phases)))))
-   (synopsis "ICU, International Components for Unicode")
+      (alist-cons-after
+       'unpack 'chdir-to-source
+       (lambda _ (chdir "source"))
+       (alist-cons-before
+        'configure 'patch-configure
+        (lambda _
+          ;; patch out two occurrences of /bin/sh from configure script
+          ;; that might have disappeared in a release later than 54.1
+          (substitute* "configure"
+            (("`/bin/sh")
+             (string-append "`" (which "bash")))))
+        %standard-phases))))
+   (synopsis "International Components for Unicode")
    (description
     "ICU is a set of C/C++ and Java libraries providing Unicode and
-globalisation support for software applications. This package contains the
+globalisation support for software applications.  This package contains the
 C/C++ part.")
    (license x11)
    (home-page "http://site.icu-project.org/")))