gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / dictionaries.scm
index ec85831..1aa54d9 100644 (file)
@@ -2,8 +2,11 @@
 ;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages dictionaries)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages emacs)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages fribidi)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages pcre)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages compression)
-  #:use-module (gnu packages tcl))
+  #:use-module (gnu packages tcl)
+  #:use-module (gnu packages xml))
 
 
 (define-public vera
@@ -86,7 +96,7 @@
     (description
      "V.E.R.A. (Virtual Entity of Relevant Acronyms) is a list of computing
 acronyms distributed as an info document.")
-    (license fdl1.3+)))
+    (license license:fdl1.3+)))
 
 (define-public gcide
   (package
@@ -124,7 +134,7 @@ acronyms distributed as an info document.")
 be used via the GNU Dico program or accessed online at
 http://gcide.gnu.org.ua/")
     (home-page "http://gcide.gnu.org.ua/")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public diction
   ;; Not quite a dictionary, not quite a spell checker either…
@@ -146,7 +156,7 @@ Diction is used to identify wordy and commonly misused phrases in a
 body of text.  Style instead analyzes surface aspects of a written
 work, such as sentence length and other readability measures.")
     (home-page "https://www.gnu.org/software/diction/")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public ding
   (package
@@ -167,8 +177,7 @@ work, such as sentence length and other readability measures.")
          (delete 'configure)
          (delete 'build)
          (delete 'check)
-         (replace
-             'install
+         (replace 'install
            (lambda _
              (let ((bindir (string-append
                             (assoc-ref %outputs "out") "/bin"))
@@ -200,29 +209,28 @@ work, such as sentence length and other readability measures.")
                   (string-append "DEFLIBDIR=\"" libdir "\"")))
                (install-file "ding.desktop" sharedir)
                (install-file "ding.png" sharedir)
-               (zero?
-                (system* "./install.sh"))))))))
+               (invoke "./install.sh")))))))
     (synopsis "Dictionary lookup program with a German-English dictionary")
     (description "Ding is a dictionary lookup program for the X window system.
 It comes with a German-English dictionary with approximately 270,000 entries.")
     (home-page  "http://www-user.tu-chemnitz.de/~fri/ding/")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public grammalecte
   (package
     (name "grammalecte")
-    (version "0.6.4")
+    (version "1.6.0")
     (source
      (origin
        (method url-fetch/zipbomb)
-       (uri (string-append "https://www.dicollecte.org/grammalecte/zip/"
+       (uri (string-append "https://grammalecte.net/grammalecte/zip/"
                            "Grammalecte-fr-v" version ".zip"))
        (sha256
         (base32
-         "13var1gi3gb2bwi7k21bn2pla0rs17cd7kc3mc5a2nsyqgsrzxfw"))))
+         "0kz13gx2hd23xd6bfr4z73lh18slj3vbvs2xcb7qvhramxjqzqcn"))))
     (build-system python-build-system)
-    (home-page "https://www.dicollecte.org")
-    (synopsis  "French spelling and grammar checker")
+    (home-page "https://grammalecte.net")
+    (synopsis "French spelling and grammar checker")
     (description "Grammalecte is a grammar checker dedicated to the French
 language, derived from Lightproof.
 
@@ -233,31 +241,50 @@ a dubious expression is wrong, it will keep silent.
 
 The package provides the command line interface, along with a server
 and a Python library.")
-    (license gpl3+)))
+    (license license:gpl3+)))
 
 (define-public translate-shell
   (package
     (name "translate-shell")
-    (version "0.9.6.7")
+    (version "0.9.6.11")
     (source
       (origin
-        (method url-fetch)
-        (uri (string-append "https://github.com/soimort/" name "/archive/v"
-                            version ".tar.gz"))
+        (method git-fetch)
+        (uri (git-reference
+               (url"https://github.com/soimort/translate-shell.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
         (sha256
-         (base32
-          "0inv6r3qbihn2ff1sgcly89r04k4vgcbvvyl50ln0mxlapbhpy95"))
-        (patches (search-patches "translate-shell-fix-curl-tests.patch"))
-        (file-name (string-append name "-" version ".tar.gz"))))
+         (base32 "137fz3ahzf65hfqcs4k7hhrmfjlhlw7wr3gfsvk88bnyqkyw44sm"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (delete 'configure) ; no configure phase
+         (delete 'configure)            ; no configure script
+         (add-after 'unpack 'remove-unnecessary-file
+           ;; This file gets generated during the build phase.
+           (lambda _
+             (delete-file "translate")
+             #t))
+         (add-after 'install 'wrap-binary
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out     (assoc-ref outputs "out"))
+                    (bin     (string-append out "/bin/trans"))
+                    (curl    (assoc-ref inputs "curl"))
+                    (fribidi (assoc-ref inputs "fribidi"))
+                    (rlwrap  (assoc-ref inputs "rlwrap")))
+               (wrap-program bin
+                             `("PATH" ":" prefix
+                               (,(string-append out "/bin:"
+                                                curl "/bin:"
+                                                fribidi "/bin:"
+                                                rlwrap "/bin")))))
+             #t))
          (add-after 'install 'emacs-install
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out   (assoc-ref outputs "out"))
-                    (dest  (string-append out "/share/emacs/site-lisp"))
+                    (dest  (string-append out "/share/emacs/site-lisp/guix.d/"
+                                          ,name "-" ,version))
                     (emacs (string-append (assoc-ref inputs "emacs") "/bin/emacs")))
                (install-file "google-translate-mode.el" dest)
                (emacs-generate-autoloads ,name dest)))))
@@ -268,13 +295,13 @@ and a Python library.")
                   (guix build emacs-utils)
                   (guix build utils))
        #:test-target "test"))
-    (propagated-inputs
+    (inputs
      `(("curl" ,curl)
        ("fribidi" ,fribidi)
        ("rlwrap" ,rlwrap)))
     (native-inputs
      `(("emacs" ,emacs-minimal)
-       ("util-linux" ,util-linux))) ; hexdump, for the test
+       ("util-linux" ,util-linux)))     ; hexdump, for the test
     (home-page "https://www.soimort.org/translate-shell/")
     (synopsis "Translations from the command line")
     (description
@@ -282,4 +309,87 @@ and a Python library.")
 translator powered by Google Translate (default), Bing Translator,
 Yandex.Translate and Apertium.  It gives you easy access to one of these
 translation engines from your terminal.")
-    (license public-domain)))
+    (license license:public-domain)))
+
+(define-public lttoolbox
+  (package
+    (name "lttoolbox")
+    (version "3.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/apertium/lttoolbox/releases/download/v"
+             version "/lttoolbox-" version ".tar.gz"))
+       (sha256
+        (base32
+         "08y6pf1hl7prwygy1g8h6ndqww18pmb9f3r5988q0pcrp8w6xz6b"))
+       (file-name (string-append name "-" version ".tar.gz"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libxml2" ,libxml2)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://wiki.apertium.org/wiki/Lttoolbox")
+    (synopsis "Lexical processing toolbox")
+    (description "Lttoolbox is a toolbox for lexical processing, morphological
+analysis and generation of words.  Analysis is the process of splitting a
+word (e.g. cats) into its lemma \"cat\" and the grammatical information
+@code{<n><pl>}.  Generation is the opposite process.")
+    (license (list license:gpl2 ; main license
+                   license:expat)))) ; utf8/*
+
+(define-public apertium
+  (package
+    (name "apertium")
+    (version "3.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/apertium/apertium/releases/download/v"
+             version "/apertium-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0lrx58ipx2kzh1pd3xm1viz05dqyrq38jbnj9dnk92c9ckkwkp4h"))
+       (file-name (string-append name "-" version ".tar.gz"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libxml2" ,libxml2)
+       ("libxslt" ,libxslt)
+       ("lttoolbox" ,lttoolbox)
+       ("pcre" ,pcre)))
+    (native-inputs
+     `(("apertium-get"
+        ,(origin
+           (method git-fetch)
+           (uri (git-reference
+                 (url "https://github.com/apertium/apertium-get")
+                 (commit "692d030e68008fc123089cf2446070fe8c6e3a3b")))
+           (sha256
+            (base32
+             "0kgp68azvds7yjwfz57z8sa5094fyk5yr0qxzblrw7bisrrihnav"))))
+       ("flex" ,flex)
+       ("pkg-config" ,pkg-config)
+       ;; python is only required for running the test suite
+       ("python" ,python)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; If apertium-get does not exist in the source tree, the build tries
+         ;; to download it using an svn checkout. To avoid this, copy
+         ;; apertium-get into the source tree.
+         (add-after 'unpack 'unpack-apertium-get
+           (lambda* (#:key inputs #:allow-other-keys)
+             (copy-recursively (assoc-ref inputs "apertium-get")
+                               "apertium/apertium-get")
+             #t)))))
+    (home-page "https://www.apertium.org/")
+    (synopsis "Rule based machine translation system")
+    (description "Apertium is a rule based machine translation system
+featuring a shallow-transfer machine translation engine.  The design of the
+system makes translations fast (translating tens of thousands of words per
+second on ordinary desktop computers) and, in spite of the errors, reasonably
+intelligible and easily correctable.")
+    (license (list license:gpl2 ; main license
+                   license:expat)))) ; utf8/*