gnu: nnn: Don't use NAME in source URI.
[jackhill/guix/guix.git] / gnu / packages / wget.scm
index bd43e37..49bc6ec 100644 (file)
@@ -3,6 +3,7 @@
 ;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -44,7 +45,7 @@
 (define-public wget
   (package
     (name "wget")
-    (version "1.19.5")
+    (version "1.20.1")
     (source
      (origin
       (method url-fetch)
                           version ".tar.lz"))
       (sha256
        (base32
-        "0xfaxmlnih7dhkyks5wi4vrn0n1xshmy6gx6fb2k1120sprydyr9"))))
+        "0a29qsqxkk8145vkyy35q5a1wc7qzwx3qj3gmfrkmi9xs96yhqqg"))))
     (build-system gnu-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-before 'check 'disable-https-tests
-                    (lambda _
-                      ;; XXX: Skip TLS tests, which fail with "The
-                      ;; certificate's owner does not match hostname" as
-                      ;; reported at:
-                      ;; <https://lists.gnu.org/archive/html/bug-wget/2017-07/msg00012.html>.
-                      ;; The problem appears to be due to a change in GnuTLS
-                      ;; 3.5.12, whereby 'gnutls_x509_crt_check_hostname2' no
-                      ;; longer matches IP address against the 'CN' or
-                      ;; 'DNSname' fields of certificates.
-                      (substitute* "testenv/Makefile"
-                        (("SSL_TESTS=1") ""))
-                      #t)))))
     (inputs
      `(("gnutls" ,gnutls)
        ("libidn2" ,libidn2)
@@ -149,9 +135,9 @@ online pastebin services.")
                       (find-files "."))
           (substitute* "./gnulib/gnulib-tool.py"
                        (("/usr/bin/python") (which "python3")))
-          (zero? (system* "sh" "./bootstrap"
+          (invoke "sh" "./bootstrap"
                           "--gnulib-srcdir=gnulib"
-                          "--no-git")))))))
+                          "--no-git"))))))
    (inputs `(("autoconf" ,autoconf)
              ("automake" ,automake)
              ("doxygen" ,doxygen)