gnu: deutex: Update to 5.2.1.
[jackhill/guix/guix.git] / gnu / packages / wv.scm
index 31afd86..866cfee 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:)))
+  #:use-module ((guix licenses) #:prefix license:))
 
 (define-public wv
   (package
     (name "wv")
     (version "1.2.4")
-    (source
-      (origin
-        (method url-fetch)
-        (uri
-          (string-append
-            "http://sourceforge.net/projects/" name "/files/wv/" version
-            "/wv-" version ".tar.gz/download"))
-        (file-name (string-append "wv-" version ".tar.gz"))
-        (sha256
-          (base32 "1mn2ax6qjy3pvixlnvbkn6ymy6y4l2wxrr4brjaczm121s8hjcb7"))))
-
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/wvware/wv/" version
+                                  "/wv-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1mn2ax6qjy3pvixlnvbkn6ymy6y4l2wxrr4brjaczm121s8hjcb7"))))
     (build-system gnu-build-system)
-    (arguments
-      `(#:configure-flags '("--with-libwmf")))
     (inputs
       `(("glib" ,glib)
         ("libgsf" ,libgsf)
         ("libjpeg" ,libjpeg)
         ("libpng" ,libpng)
-        ("libwmf" ,libwmf)
         ("zlib" ,zlib)))
     (native-inputs
       `(("glib" ,glib "bin")
         ("pkg-config" ,pkg-config)))
     (synopsis "Microsoft Word conversion library and utilities")
     (description
-      "wv converts Word 2,6,7,8,9 files to HTML and LaTeX.  The Word 2
-conversion is still incomplete (no formatting), but it will do a passable job
-extracting the text, which is what you probably want anyway.
+     "wv converts files written by Word 2000, 97, 95, and 6 (known internally as
+Word 9, 8, 7, and 6) to HTML or LaTeX.  Word 2 documents can still be converted
+to plain text but will lack formatting.
 
-libwv can be used as a library by third party programs, AbiWord uses it as its
-word importer, and KWord may use it in the future.")
+Othe programs can use wv as a library to convert Word documents to other
+formats.  AbiWord uses it as its Word importer, and KWord uses concepts and
+code from wv in theirs.")
     (home-page "http://wvware.sourceforge.net/")
     (license license:gpl2+)))