gnu: Move brlaser to (gnu packages cups).
[jackhill/guix/guix.git] / gnu / packages / printers.scm
index e03582c..9ab9da3 100644 (file)
@@ -1,7 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-module (gnu packages printers)
   #:use-module (guix packages)
   #:use-module (guix git-download)
-  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module ((guix licenses) #:prefix license:)
-  #:use-module (gnu packages compression)
-  #:use-module (gnu packages cups)
   #:use-module (gnu packages libusb)
-  #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages qt))
 
 with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
     (home-page "http://robocut.org")
     (license license:gpl3+)))
-
-(define-public brlaser
-  (let ((commit "9d7ddda8383bfc4d205b5e1b49de2b8bcd9137f1")
-        (revision "1"))
-    (package
-      (name "brlaser")
-      (version (git-version "6" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/pdewacht/brlaser")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1drh0nk7amn9a8wykki4l9maqa4vy7vwminypfy1712alwj31nd4"))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:configure-flags
-         (list (string-append "-DCUPS_DATA_DIR="
-                              (assoc-ref %outputs "out")
-                              "/share/cups")
-               (string-append "-DCUPS_SERVER_BIN="
-                              (assoc-ref %outputs "out")
-                              "/lib/cups"))))
-      (inputs
-       `(("ghostscript" ,ghostscript)
-         ("cups" ,cups)
-         ("zlib" ,zlib)))
-      (home-page "https://github.com/pdewacht/brlaser")
-      (synopsis "Brother laser printer driver")
-      (description "Brlaser is a CUPS driver for Brother laser printers.  This
-driver is known to work with these printers:
-
-@enumerate
-@item Brother DCP-1510 series
-@item Brother DCP-1600 series
-@item Brother DCP-7030
-@item Brother DCP-7040
-@item Brother DCP-7055
-@item Brother DCP-7055W
-@item Brother DCP-7060D
-@item Brother DCP-7065DN
-@item Brother DCP-7080
-@item Brother DCP-L2500D series
-@item Brother DCP-L2520D series
-@item Brother DCP-L2540DW series
-@item Brother HL-1110 series
-@item Brother HL-1200 series
-@item Brother HL-2030 series
-@item Brother HL-2140 series
-@item Brother HL-2220 series
-@item Brother HL-2270DW series
-@item Brother HL-5030 series
-@item Brother HL-L2300D series
-@item Brother HL-L2320D series
-@item Brother HL-L2340D series
-@item Brother HL-L2360D series
-@item Brother MFC-1910W
-@item Brother MFC-7240
-@item Brother MFC-7360N
-@item Brother MFC-7365DN
-@item Brother MFC-7840W
-@item Brother MFC-L2710DW series
-@item Lenovo M7605D
-@end enumerate")
-      (license license:gpl2+))))