gnu: Separate Python core packages from the rest.
[jackhill/guix/guix.git] / gnu / packages / irc.scm
index 2b26674..98d0e8d 100644 (file)
@@ -30,6 +30,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
+  #:use-module (gnu packages admin)
   #:use-module (gnu packages aspell)
   #:use-module (gnu packages autogen)
   #:use-module (gnu packages autotools)
@@ -53,6 +54,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-crypto)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages tcl)
@@ -65,7 +67,7 @@
 (define-public quassel
   (package
     (name "quassel")
-    (version "0.12.5")
+    (version "0.13.0")
     (source
       (origin
         (method url-fetch)
@@ -73,7 +75,7 @@
                             version ".tar.bz2"))
         (sha256
          (base32
-          "1qkl3sb4ijx4k17m0c42j2p5bc4jymypwhmplm942rbrzm6mg50q"))
+          "0xp9mppxl63qzgsdyprmblvfrj0bb9z57kfc088gvcavvq1210nr"))
         (modules '((guix build utils)))
         ;; We don't want to install the bundled scripts.
         (snippet
     (arguments
       ;; The three binaries are not mutually exlusive, and are all built
       ;; by default.
-     '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 5.2 MiB
-                           ;;"-DWANT_CORE=OFF" ; 2.4 MiB
-                           ;;"-DWANT_MONO=OFF" ; 6.4 MiB
-                           "-DUSE_QT5=ON" ; default is qt4
+     '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 6.1 MiB
+                           ;;"-DWANT_CORE=OFF" ; 3.0 MiB
+                           ;;"-DWANT_MONO=OFF" ; 7.6 MiB
                            "-DWITH_KDE=OFF" ; no to kde integration ...
-                           "-DWITH_OXYGEN=ON" ; therefore we install bundled icons
-                           "-DWITH_WEBKIT=OFF") ; qtwebkit isn't packaged
+                           "-DWITH_BUNDLED_ICONS=ON" ; so we install bundled icons
+                           "-DWITH_OXYGEN_ICONS=ON" ; also the oxygen ones
+                           "-DWITH_WEBENGINE=OFF") ; we don't depend on qtwebengine
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-inxi-reference
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((inxi (string-append (assoc-ref inputs "inxi") "/bin/inxi")))
+               (substitute* "src/common/aliasmanager.cpp"
+                 ((" inxi ") (string-append " " inxi " ")))
+               #t))))
        #:tests? #f)) ; no test target
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)
        ("qttools" ,qttools)))
     (inputs
-     `(("qca" ,qca)
+     `(("inxi" ,inxi-minimal)
+       ("qca" ,qca)
        ("qtbase" ,qtbase)
+       ("qtmultimedia" ,qtmultimedia)
        ("qtscript" ,qtscript)
        ("snorenotify" ,snorenotify)
        ("zlib" ,zlib)))
@@ -115,15 +127,15 @@ irssi, but graphical.")
 (define-public irssi
   (package
     (name "irssi")
-    (version "1.1.1")
+    (version "1.1.2")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "https://github.com/irssi/irssi/"
-                                 "releases/download/" version "/irssi-"
-                                 version ".tar.xz"))
-             (sha256
-              (base32
-               "1gx1flfh4a09nb3b5pvf0ygnbl7rry3l4gph8wij29dsl7khfj3q"))))
+              (method url-fetch)
+              (uri (string-append "https://github.com/irssi/irssi/"
+                                  "releases/download/" version "/irssi-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0clppwqhllrmqjg1dd47v9v1qiqx7cf9afm81bm1pscllf4jpk2w"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -132,12 +144,11 @@ irssi, but graphical.")
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (setenv "CONFIG_SHELL" (which "bash"))
-               (zero?
-                (system* "./configure"
-                         (string-append "--prefix=" out)
-                         (string-append "--with-proxy")
-                         (string-append "--with-socks")
-                         (string-append "--with-bot")))))))))
+               (invoke "./configure"
+                       (string-append "--prefix=" out)
+                       (string-append "--with-proxy")
+                       (string-append "--with-socks")
+                       (string-append "--with-bot"))))))))
     (inputs
      `(("glib" ,glib)
        ("ncurses" ,ncurses)
@@ -404,21 +415,20 @@ other enhancements and bug fixes.")
                      '())
                (setenv "CONFIG_SHELL" (which "bash"))
                (setenv "SHELL" (which "bash"))
-               (zero?
-                (system* "./configure"
-                         (string-append "--prefix=" out)
-                         "--with-ipv6" "--with-libarchive"
-                         ;; We use libressl because openssl does not come
-                         ;; with the lib/libssl.a which is needed for epic5.
-                         ;; XXX: No matter which implementation is chosen,
-                         ;; epic5 fails to connect to tls ports of roundrobin
-                         ;; irc networks. This however is believed to be an
-                         ;; protocol issue at epic5 related to ircd.
-                         (string-append "--with-ssl="
-                                        (assoc-ref %build-inputs "libressl"))
-                         (string-append "--with-tcl="
-                                        (assoc-ref %build-inputs "tcl")
-                                        "/lib/tclConfig.sh")))))))))
+               (invoke "./configure"
+                       (string-append "--prefix=" out)
+                       "--with-ipv6" "--with-libarchive"
+                       ;; We use libressl because openssl does not come
+                       ;; with the lib/libssl.a which is needed for epic5.
+                       ;; XXX: No matter which implementation is chosen,
+                       ;; epic5 fails to connect to tls ports of roundrobin
+                       ;; irc networks. This however is believed to be an
+                       ;; protocol issue at epic5 related to ircd.
+                       (string-append "--with-ssl="
+                                      (assoc-ref %build-inputs "libressl"))
+                       (string-append "--with-tcl="
+                                      (assoc-ref %build-inputs "tcl")
+                                      "/lib/tclConfig.sh"))))))))
     (inputs
      `(("libressl" ,libressl)
        ("ncurses" ,ncurses)