gnu: r-abaenrichment: Update to 1.14.0.
[jackhill/guix/guix.git] / gnu / packages / c.scm
index d89b6ea..2629ebb 100644 (file)
@@ -1,8 +1,9 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -38,7 +39,7 @@
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages pkg-config)
-  #:use-module (srfi srfi-1))
+  #:use-module (gnu packages xml))
 
 (define-public tcc
   (package
                                               "/include:{B}/include")
                                (string-append "--libpaths="
                                               (assoc-ref %build-inputs "libc")
-                                              "/lib"))
+                                              "/lib")
+                               ,@(if (string-prefix? "armhf-linux"
+                                                     (or (%current-target-system)
+                                                         (%current-system)))
+                                     `("--triplet=arm-linux-gnueabihf")
+                                     '()))
        #:test-target "test"))
     ;; Fails to build on MIPS: "Unsupported CPU"
-    (supported-systems (fold delete %supported-systems
-                             '("mips64el-linux" "aarch64-linux")))
+    (supported-systems (delete "mips64el-linux" %supported-systems))
     (synopsis "Tiny and fast C compiler")
     (description
      "TCC, also referred to as \"TinyCC\", is a small and fast C compiler
@@ -185,8 +190,45 @@ compiler while still keeping it small, simple, fast and understandable.")
                     "download/" version "/libbytesize-" version ".tar.gz"))
               (sha256
                (base32
-                "0bbqzln1nhjxl71aydq9k4jg3hvki9lqsb4w10s1i27jgibxqkdv"))))
+                "0bbqzln1nhjxl71aydq9k4jg3hvki9lqsb4w10s1i27jgibxqkdv"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; This Makefile hard-codes MSGMERGE et al. instead of
+                  ;; honoring what 'configure' detected.  Fix that.
+                  (substitute* "po/Makefile.in"
+                    (("^MSGMERGE = msgmerge")
+                     "MSGMERGE = @MSGMERGE@\n"))
+                  #t))))
     (build-system gnu-build-system)
+    (arguments
+     ;; When running "make", the POT files are built with the build time as
+     ;; their "POT-Creation-Date".  Later on, "make" notices that .pot
+     ;; files were updated and goes on to run "msgmerge"; as a result, the
+     ;; non-deterministic POT-Creation-Date finds its way into .po files,
+     ;; and then in .gmo files.  To avoid that, simply make sure 'msgmerge'
+     ;; never runs.  See <https://bugs.debian.org/792687>.
+     '(#:configure-flags '("ac_cv_path_MSGMERGE=true")
+
+       #:phases (modify-phases %standard-phases
+                  (add-after 'configure 'create-merged-po-files
+                    (lambda _
+                      ;; Create "merged PO" (.mpo) files so that 'msgmerge'
+                      ;; doesn't need to run.
+                      (for-each (lambda (po-file)
+                                  (let ((merged-po
+                                         (string-append (dirname po-file) "/"
+                                                        (basename po-file
+                                                                  ".po")
+                                                        ".mpo")))
+                                    (copy-file po-file merged-po)))
+                                (find-files "po" "\\.po$"))
+                      #t)))
+
+       ;; One test fails because busctl (systemd only?) and python2-pocketlint
+       ;; are missing.  Should we fix it, we would need the "python-2" ,
+       ;; "python2-polib" and "python2-six" native-inputs.
+       #:tests? #f))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)
@@ -194,10 +236,6 @@ compiler while still keeping it small, simple, fast and understandable.")
     (inputs
      `(("mpfr" ,mpfr)
        ("pcre" ,pcre)))
-    ;; One test fails because busctl (systemd only?) and python2-pocketlint
-    ;; are missing.  Should we fix it, we would need the "python-2" ,
-    ;; "python2-polib" and "python2-six" native-inputs.
-    (arguments `(#:tests? #f))
     (home-page "https://github.com/storaged-project/libbytesize")
     (synopsis "Tiny C library for working with arbitrary big sizes in bytes")
     (description
@@ -220,3 +258,32 @@ typing conventions?
 every project that needs to deal with sizes in bytes.  It is written in the C
 language with thin bindings for other languages.")
     (license license:lgpl2.1+)))
+
+(define-public udunits
+  (package
+    (name "udunits")
+    (version "2.2.26")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "ftp://ftp.unidata.ucar.edu/pub/udunits/"
+                                  "udunits-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0v9mqw4drnkzkm57331ail6yvs9485jmi37s40lhvmf7r5lli3rn"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("expat" ,expat)))
+    (home-page "https://www.unidata.ucar.edu/software/udunits/")
+    (synopsis "C library for units of physical quantities and value-conversion utils")
+    (description
+     "The UDUNITS-2 package provides support for units of physical quantities.
+Its three main components are:
+
+@enumerate
+@item @code{udunits2lib}, a C library for units of physical quantities;
+@item @code{udunits2prog}, a utility for obtaining the definition of a unit
+  and for converting numeric values between compatible units; and
+@item an extensive database of units.
+@end enumerate\n")
+    ;; Like the BSD-3 license but with an extra anti patent clause.
+    (license (license:non-copyleft "file://COPYRIGHT"))))