gnu: datefudge: Update to 1.23.
[jackhill/guix/guix.git] / gnu / packages / simulation.scm
index 3637cc3..edc8d6e 100644 (file)
@@ -464,6 +464,10 @@ FFC is part of the FEniCS Project.")
                               "${DOLFIN_SOURCE_DIR} "
                               "${DOLFIN_SOURCE_DIR}/dolfin "
                               "${DOLFIN_BINARY_DIR})\n")))
+            (substitute* "dolfin/nls/PETScSNESSolver.cpp"
+              ;; Remove SNESTEST mapping.  The SNESTEST symbol was removed
+              ;; from PETSc at version 3.10.3.
+              ((".*SNESTEST.*") "" ))
             #t))))
     (build-system cmake-build-system)
     (inputs
@@ -616,7 +620,7 @@ user interface to the FEniCS core components and external libraries.")
        ("python-matplotlib" ,python-matplotlib)
        ,@(alist-delete "python" (package-inputs fenics-dolfin))))
     (native-inputs
-     `(("cmake" ,cmake)
+     `(("cmake" ,cmake-minimal)
        ("ply" ,python-ply)
        ("pytest" ,python-pytest)
        ("python-decorator" ,python-decorator)