Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / web.scm
index 7d41b61..3b0cbae 100644 (file)
@@ -32,6 +32,7 @@
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -74,6 +75,7 @@
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
-  #:use-module (gnu packages valgrind)
-  #:use-module (gnu packages xml)
-  #:use-module (gnu packages curl)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
-  #:use-module (gnu packages version-control))
+  #:use-module (gnu packages valgrind)
+  #:use-module (gnu packages version-control)
+  #:use-module (gnu packages xml))
 
 (define-public httpd
   (package
@@ -200,14 +202,14 @@ Interface} specification.")
     ;; ’stable’ and recommends that “in general you deploy the NGINX mainline
     ;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
     ;; Consider updating the nginx-documentation package together with this one.
-    (version "1.15.12")
+    (version "1.17.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://nginx.org/download/nginx-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1giavdph0jqhywdkj4650s5qhz6qfd6nrv74k9q005yy2ym90nrx"))))
+                "1aqgmrjzmklmv2iiyirk2h0hy35v1a76gczhjkxnms2krl35s6z2"))))
     (build-system gnu-build-system)
     (inputs `(("openssl" ,openssl)
               ("pcre" ,pcre)
@@ -854,7 +856,7 @@ for efficient socket-like bidirectional reliable communication channels.")
 (define-public libpsl
   (package
     (name "libpsl")
-    (version "0.20.2")
+    (version "0.21.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/rockdaboot/libpsl/"
@@ -862,7 +864,7 @@ for efficient socket-like bidirectional reliable communication channels.")
                                   "/libpsl-" version ".tar.gz"))
               (sha256
                (base32
-                "03sn3fbcrmgl9x2f1gc6rbrdlbrnwbhrnkgi733gqb95cvmhmzgq"))))
+                "04pfagb7ppq3yibx4lhazd1v9nwkxdfkyy2rgcrmrf3mldsirga1"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -3082,14 +3084,14 @@ and IPv6 sockets, intended as a replacement for IO::Socket::INET.")
 (define-public perl-io-socket-ssl
   (package
     (name "perl-io-socket-ssl")
-    (version "2.038")
+    (version "2.066")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://cpan/authors/id/S/SU/SULLR/"
                                   "IO-Socket-SSL-" version ".tar.gz"))
               (sha256
                (base32
-                "11fiifxyvn7njc9p52wgygyw24jz7rh7gnz2ikjphr4l4x9f03rx"))
+                "1kgbws7dwp2hh16qid7169dfkhmcwg7dz9ffbm6k0id5h53hciqd"))
               (patches (search-patches
                         "perl-io-socket-ssl-openssl-1.0.2f-fix.patch"))))
     (build-system perl-build-system)
@@ -4233,27 +4235,19 @@ NetSurf project.")
 (define-public ikiwiki
   (package
     (name "ikiwiki")
-    (version "3.20170111")
+    (version "3.20190228")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "http://snapshot.debian.org/archive/debian/"
-                           "20170111T215449Z/pool/main/i/ikiwiki/ikiwiki_"
-                           version ".tar.xz"))
+                           "20190301T035241Z/pool/main/i/ikiwiki/ikiwiki_"
+                           version ".orig.tar.xz"))
        (sha256
         (base32
-         "00d7yzv426fvqbhvzyafddv7fa6b4j2647b0wi371wd5yjj9j3sz"))))
+         "17pyblaqhkb61lxl63bzndiffism8k859p54k3k4sghclq6lsynh"))))
     (build-system perl-build-system)
     (arguments
-     `(;; Image tests fail
-       ;;
-       ;; Test Summary Report
-       ;; -------------------
-       ;; t/img.t                      (Wstat: 2304 Tests: 62 Failed: 9)
-       ;;   Failed tests:  21, 27-28, 30-35
-       ;;   Non-zero exit status: 9
-       #:tests? #f
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'include-PERL5LIB-in-wrapper
            (lambda _
@@ -4818,14 +4812,14 @@ tools like SSH (Secure Shell) to reach the outside world.")
 (define-public stunnel
   (package
   (name "stunnel")
-  (version "5.54")
+  (version "5.55")
   (source
     (origin
       (method url-fetch)
       (uri (string-append "https://www.stunnel.org/downloads/stunnel-"
                           version ".tar.gz"))
       (sha256
-       (base32 "00krr0h3vsyi93mqhrbgfgn8v47l4l3hzdg1ccfnpd3lqak8i1ay"))))
+       (base32 "0qjc0wkjf6bqz29fvwwsn9hnjhm6alsm10jcwx4jad2q3ks6kplh"))))
   (build-system gnu-build-system)
   (native-inputs
    ;; For tests.
@@ -5286,7 +5280,7 @@ command-line arguments or read from stdin.")
     (synopsis "Command-line interface to archive.org")
     (description "@code{ia} is a command-line tool for using
 @url{archive.org} from the command-line.  It also emplements the
-internetarchive python module for programatic access to archive.org.")
+internetarchive python module for programmatic access to archive.org.")
     (properties
      `((python2-variant . ,(delay python2-internetarchive))))
     (license license:agpl3+)))
@@ -5605,7 +5599,7 @@ technologies.")
        ("hamcrest" ,java-hamcrest-all)))
     (home-page "https://www.eclipse.org/jetty/")
     (synopsis "Helper classes for jetty tests")
-    (description "This packages contains helper classes for testing the Jetty
+    (description "This package contains helper classes for testing the Jetty
 Web Server.")
     ;; This program is licensed under both epl and asl.
     (license (list license:epl1.0 license:asl2.0))))
@@ -6312,7 +6306,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
 (define-public nghttp2
   (package
     (name "nghttp2")
-    (version "1.35.1")
+    (version "1.39.1")
     (source
      (origin
        (method url-fetch)
@@ -6321,13 +6315,12 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "0fi6qg2w82636wixwkqy7bclpgxslmvg82r431hs8h6aqc4mnzwv"))))
+         "0j0lk37k8k3f61r9nw647hg4b22z1753l36n3xrp9x01civ614b7"))))
     (build-system gnu-build-system)
     (outputs (list "out"
                    "lib"))              ; only libnghttp2
     (native-inputs
      `(("pkg-config" ,pkg-config)
-       ("gcc" ,gcc-7)                   ; 1.35.0 requires GCC6 or later
 
        ;; Required by tests.
        ("cunit" ,cunit)
@@ -6359,9 +6352,6 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
                (("@prefix@")
                 (assoc-ref outputs "lib")))
              #t))
-         (add-before 'configure 'work-around-bug-30756
-           (lambda _
-             (for-each unsetenv '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH")) #t))
          (add-before 'check 'set-timezone-directory
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")
@@ -6384,7 +6374,7 @@ serves files from a local directory.
 @item @command{nghttpx}, a fast, multi-threaded HTTP/2 reverse proxy that can be
 deployed in front of existing web servers that don't support HTTP/2.
 Both @command{nghttpd} and @command{nghttpx} can fall back to HTTP/1.1 for
-backwards compatibilty with clients that don't speak HTTP/2.
+backwards compatibility with clients that don't speak HTTP/2.
 @item @command{h2load} for benchmarking (only!) your own HTTP/2 servers.
 @item HTTP/2 uses a header compression method called @dfn{HPACK}.
 nghttp2 provides a HPACK encoder and decoder as part of its public API.