gnu: Add java-sonatype-spice-parent-pom-17.
[jackhill/guix/guix.git] / gnu / packages / maven-parent-pom.scm
index 6463724..4f9daa2 100644 (file)
 (define-public apache-parent-pom-19
   (make-apache-parent-pom
     "19" "02drnwv2qqk1dmxbmmrk0bi1iil5cal9l47w53ascpbjg6242mp1"))
+
+(define-public apache-parent-pom-21
+  (make-apache-parent-pom
+    "21" "0clcbrq1b2b8sbvlqddyw2dg5niq25dhdma9sk4b0i30hqaipx96"))
+
+(define (make-apache-commons-parent-pom version hash parent)
+  (hidden-package
+    (package
+      (name "apache-commons-parent-pom")
+      (version version)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/apache/commons-parent")
+                       (commit (string-append "commons-parent-" version))))
+                (file-name (git-file-name name version))
+                (sha256 (base32 hash))))
+      (build-system ant-build-system)
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (delete 'build)
+           (replace 'install
+             (install-pom-file "pom.xml")))))
+      (propagated-inputs
+        (if parent
+            `(("parent" ,parent))
+            '()))
+      (home-page "https://maven.apache.org/")
+      (synopsis "Apache Commons parent pom")
+      (description "This package contains the Apache Commons parent POM.")
+      (license license:asl2.0))))
+
+(define-public apache-commons-parent-pom-39
+  (make-apache-commons-parent-pom
+    "39" "0mjx48a55ik1h4hsxhifkli1flvkp6d05ab14p4al0fc6rhdxi46"
+    apache-parent-pom-16))
+
+(define-public apache-commons-parent-pom-41
+  (make-apache-commons-parent-pom
+    "41" "1k184amdqdx62bb2k0m9v93zzx768qcyam5dvdgksqc1aaqhadlb"
+    apache-parent-pom-18))
+
+(define-public apache-commons-parent-pom-48
+  (make-apache-commons-parent-pom
+    "48" "0dk8qp7swbh4y1q7q34y14yhigzl5yz0ixa8jhhhq91yc2q570iq"
+    apache-parent-pom-21))
+
+(define-public apache-commons-parent-pom-50
+  (make-apache-commons-parent-pom
+    "50" "0ki8px35dan51ashblpw6rdl27c2fq62slazhslhq3lr4fwlpvxs"
+    apache-parent-pom-21))
+
+(define-public java-weld-parent-pom
+  (hidden-package
+    (package
+      (name "java-weld-parent-pom")
+      (version "36")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/weld/parent")
+                       (commit version)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0rbvizcsma456mw9fvp4dj9cljh97nswvhi04xhczi38j5bgal0m"))))
+      (build-system ant-build-system)
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'build)
+           (replace 'install
+             (install-pom-file "pom.xml")))))
+      (home-page "https://github.com/weld/parent")
+      (synopsis "Pom parent file for weld projects")
+      (description "This package contains the parent Maven Pom for weld projects.")
+      (license license:asl2.0))))
+
+(define (make-java-sonatype-forge-parent-pom version hash)
+  (hidden-package
+    (package
+      (name "java-sonatype-forge-parent-pom")
+      (version version)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/sonatype/oss-parents")
+                       (commit (string-append "forge-parent-" version))))
+                (file-name (git-file-name name version))
+                (sha256 (base32 hash))))
+      (build-system ant-build-system)
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'build)
+           (delete 'configure)
+           (replace 'install
+             (install-pom-file "pom.xml")))))
+      (home-page "https://github.com/sonatype/oss-parents")
+      (synopsis "Sonatype forge parent pom")
+      (description "This package contains a single pom.xml file that is used by
+other projects as their parent pom.")
+      (license license:asl2.0))))
+
+(define-public java-sonatype-forge-parent-pom-4
+  (make-java-sonatype-forge-parent-pom
+    "4" "1gip239ar20qzy6yf37r6ks54bl7gqi1v49p65manrz84cmad0dh"))
+
+(define-public java-sonatype-forge-parent-pom-5
+  (make-java-sonatype-forge-parent-pom
+    "5" "0pr60wyjmaml4flmcij6l94b72ryx5gsiiasiwvcvrz9b2fkb3cd"))
+
+(define-public java-sonatype-forge-parent-pom-6
+  (make-java-sonatype-forge-parent-pom
+    "6" "0sa5wn5kc6y74m9g3azkm5i9d7kvyvgdw7wjlp7bjgy9s5qkbhgz"))
+
+(define-public java-sonatype-forge-parent-pom-10
+  (make-java-sonatype-forge-parent-pom
+    "10" "1n89wb00q4s9nwpqq6q1h4nzakw1l1rppjygxkl3iid7m5fnj60n"))
+
+(define-public java-sonatype-spice-parent-pom-15
+  (hidden-package
+    (package
+      (name "java-sonatype-spice-parent-pom")
+      (version "15")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/sonatype/oss-parents")
+                       ;; The only commit where spice-parent is version 15
+                       (commit "a4d1169c66fb21b214cb3eff2f056ec3e3695ca7")))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0h62h6m31srmqnd1bhyspz6hdhkkv48knkj0ximq3pzdixgzyxgy"))))
+      (build-system ant-build-system)
+      (propagated-inputs
+       `(("java-sonatype-forge-parent-pom-5" ,java-sonatype-forge-parent-pom-5)))
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'build)
+           (delete 'configure)
+           (replace 'install
+             (install-pom-file "pom.xml")))))
+      (home-page "https://github.com/sonatype/oss-parents")
+      (synopsis "Sonatype spice parent pom")
+      (description "This package contains a single pom.xml file that is used by
+other projects as their parent pom.")
+      (license license:asl2.0))))
+
+(define-public java-sonatype-spice-parent-pom-17
+  (hidden-package
+    (package
+      (inherit java-sonatype-spice-parent-pom-15)
+      (version "17")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/sonatype/oss-parents")
+                       (commit "spice-parent-17")))
+                (file-name (git-file-name "java-sonatype-spice-parent-pom" version))
+                (sha256
+                 (base32
+                  "1d4jh1scgnjwhv8f0r052vrksg0kman09hslfvfvpfidl8rwiigq"))))
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'build)
+           (delete 'configure)
+           (replace 'install
+             (install-pom-file "spice-parent/pom.xml")))))
+      (propagated-inputs
+       `(("java-sonatype-forge-parent-pom-10" ,java-sonatype-forge-parent-pom-10))))))