tests: hackage: Fix mock urls.
[jackhill/guix/guix.git] / gnu / packages / synergy.scm
index 905ef82..7f8a30f 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public synergy
   (package
     (name "synergy")
-    (version "1.7.3")
+    (version "1.8.2")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "https://github.com/synergy/synergy/archive/"
+      (uri (string-append "https://github.com/symless/synergy/archive/"
                           "v" version "-stable.tar.gz"))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32
-        "098y71fiw1n5i7g1p6vjfs5rz472j192p9izz2axxxhfvcyzrvx4"))
+        "1ym9lmnm64i1bw4spxq40drb4nvzsq5z7zq1935aq0kgccccg11g"))
       (modules '((guix build utils)))
       (snippet
        ;; Remove ~14MB of unnecessary bundled source and binaries
     (arguments
      `(#:phases
        (let ((srcdir (string-append "../synergy-" ,version "-stable")))
-         (alist-cons-before
-          'configure 'unpack-aux-src
-          ;; TODO: package and use from system
-          (lambda* (#:key inputs #:allow-other-keys)
-            (let ((unzip (string-append
-                          (assoc-ref inputs "unzip")
-                          "/bin/unzip")))
-              (with-directory-excursion "ext"
-                (for-each
-                 (lambda (f)
-                   (system* unzip "-d" f (string-append f ".zip")))
-                 '("gmock-1.6.0" "gtest-1.6.0")))))
-          (alist-replace
-           'check
-           ;; Don't run "integtests" as it requires network and X an display.
-           (lambda _
-             (zero? (system* (string-append srcdir "/bin/unittests"))))
-           (alist-replace
-            'install
+         (modify-phases %standard-phases
+           (add-before 'configure 'unpack-aux-src
+             ;; TODO: package and use from system
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((unzip (string-append
+                             (assoc-ref inputs "unzip")
+                             "/bin/unzip")))
+                 (with-directory-excursion "ext"
+                   (for-each
+                    (lambda (f)
+                      (system* unzip "-d" f (string-append f ".zip")))
+                    '("gmock-1.6.0" "gtest-1.6.0"))))))
+          (replace 'check
+            ;; Don't run "integtests" as it requires network and X an display.
+            (lambda _
+              (zero? (system* (string-append srcdir "/bin/unittests")))))
+          (replace 'install
             ;; There currently is no installation process, see:
             ;; http://synergy-project.org/spit/issues/details/3317/
             (lambda* (#:key outputs #:allow-other-keys)
                      (install-file (string-append srcdir "/doc/" e) ex))
                    '("synergy.conf.example"
                      "synergy.conf.example-advanced"
-                     "synergy.conf.example-basic")))))
-            %standard-phases))))))
-    (home-page "http://www.synergy-project.org")
+                     "synergy.conf.example-basic"))))))))))
+    (home-page "http://symless.com/")
     (synopsis "Mouse and keyboard sharing utility")
     (description
      "Synergy brings your computers together in one cohesive experience; its