gnu: r-rcpphnsw: Update to 0.3.0.
[jackhill/guix/guix.git] / gnu / packages / chez.scm
index d08363a..df9d68a 100644 (file)
@@ -46,7 +46,7 @@
     (origin
       (method git-fetch)
       (uri (git-reference
-            (url "https://github.com/nanopass/nanopass-framework-scheme.git")
+            (url "https://github.com/nanopass/nanopass-framework-scheme")
             (commit (string-append "v" version))))
       (sha256 (base32 "0lrngdna6w7v9vlp1a873hgwrwsz2p0pgkccswa4smzvdyhgfsri"))
       (file-name (git-file-name "nanopass" version)))))
@@ -56,7 +56,7 @@
     (origin
       (method git-fetch)
       (uri (git-reference
-            (url "https://github.com/dybvig/stex.git")
+            (url "https://github.com/dybvig/stex")
             (commit (string-append "v" version))))
       (sha256 (base32 "1jiawhhqnsj42hzmlbq5xby3iarhf8vhiqs0kg1a0zg5jsn6cf8n"))
       (file-name (git-file-name "stex" version)))))
@@ -69,7 +69,7 @@
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/cisco/ChezScheme.git")
+             (url "https://github.com/cisco/ChezScheme")
              (commit (string-append "v" version))))
        (sha256
         (base32 "1hagrqdp649n2g0wq2a9gfnz7mjcjakkw7ziplbj3db412bb7kx5"))
@@ -230,7 +230,7 @@ and 32-bit PowerPC architectures.")
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/fedeinthemix/chez-srfi.git")
+             (url "https://github.com/fedeinthemix/chez-srfi")
              (commit (string-append "v" version))))
        (sha256
         (base32 "1vgn984mj2q4w6r2q66h7qklp2hrh85wwh4k9yisga5fi0ps7myf"))
@@ -240,7 +240,9 @@ and 32-bit PowerPC architectures.")
      `(("chez-scheme" ,chez-scheme)))
     (arguments
      `(#:make-flags (let ((out (assoc-ref %outputs "out")))
-                      (list (string-append "PREFIX=" out)))
+                      (list (string-append "PREFIX=" out)
+                            "CHEZ=chez-scheme --libdirs ./"
+                            (string-append "chezversion=" ,(package-version chez-scheme))))
        #:test-target "test"
        #:phases (modify-phases %standard-phases
                   (delete 'configure))))
@@ -261,7 +263,7 @@ and 32-bit PowerPC architectures.")
        (origin
          (method git-fetch)
          (uri (git-reference
-               (url "https://github.com/arcfide/ChezWEB.git")
+               (url "https://github.com/arcfide/ChezWEB")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
@@ -326,7 +328,7 @@ programming in Scheme.")
        (origin
          (method git-fetch)
          (uri (git-reference
-               (url "https://github.com/arcfide/chez-sockets.git")
+               (url "https://github.com/arcfide/chez-sockets")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
@@ -414,9 +416,13 @@ Chez Scheme.")
 ;; files.
 (define (chez-make-flags name version)
   `(let ((out (assoc-ref %outputs "out")))
-     (list (string-append "PREFIX=" out)
-           (string-append "DOCDIR=" out "/share/doc/"
-                          ,name "-" ,version))))
+     (list
+      ;; Set 'chezversion' so that libraries are installed in
+      ;; 'lib/csvX.Y.Z-site' like Chez's 'native-search-paths' expects.
+      (string-append "chezversion=" ,(package-version chez-scheme))
+      (string-append "PREFIX=" out)
+      (string-append "DOCDIR=" out "/share/doc/"
+                     ,name "-" ,version))))
 
 (define-public chez-matchable
   (package
@@ -456,7 +462,7 @@ Chez Scheme.")
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/fedeinthemix/chez-irregex.git")
+             (url "https://github.com/fedeinthemix/chez-irregex")
              (commit (string-append "v" version))))
        (sha256
         (base32 "0jh6piylw545j81llay9wfivgpv6lcnwd81gm4w17lkasslir50q"))