gnu: emacs-extempore-mode: Update to 0.0.0-1.09518ae.
[jackhill/guix/guix.git] / gnu / packages / wordnet.scm
index dd3cdf3..03dadd4 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -23,6 +23,7 @@
   #:use-module (guix licenses)
   #:use-module (guix download)
   #:use-module (gnu packages)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages tcl))
 
 (define-public wordnet
                                "CFLAGS=-DUSE_INTERP_RESULT -O2")
        #:phases
        (modify-phases %standard-phases
+         (add-before 'build 'build-libwn-PIC
+           (lambda _
+             ;; GNU Dico links libWN.a in its wordnet.so plugin, so it needs
+             ;; PIC.
+             (invoke "make" "-C" "lib" "CFLAGS=-O2 -g -fPIC"
+                     "LDFLAGS=-fPIC")))
          (add-after 'install 'post-install
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
                #t))))))
     (outputs '("out"
                "tk"))                             ; for the Tcl/Tk GUI
+
     (inputs `(("tk" ,tk)
               ("tcl" ,tcl)))
-    (home-page "http://wordnet.princeton.edu/")
+    (home-page "https://wordnet.princeton.edu/")
     (synopsis "Lexical database for the English language")
     (description
      "WordNet is a large lexical database of English.  Nouns, verbs,