gnu: calibre: Build with non-modular Qt.
[jackhill/guix/guix.git] / gnu / packages / curl.scm
index 3e435f4..222910b 100644 (file)
@@ -3,6 +3,7 @@
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public curl
   (package
    (name "curl")
-   (version "7.45.0")
+   (version "7.47.0")
    (source (origin
             (method url-fetch)
-            (uri (string-append "http://curl.haxx.se/download/curl-"
+            (uri (string-append "https://curl.haxx.se/download/curl-"
                                 version ".tar.lzma"))
             (sha256
              (base32
-              "0bamqik0mi2rmai016iakwrwmsz0s5xad1ghkbwsd3zkv08rgkcn"))))
+              "1n284wdqzwb4bkmv0fnh36zl6lhlzy3clw2b7pn28kpgdy09ly7p"))))
    (build-system gnu-build-system)
    (outputs '("out"
               "doc"))                             ;1.2 MiB of man3 pages
@@ -95,8 +96,8 @@
            ;; test 1510...[HTTP GET connection cache limit (CURLOPT_MAXCONNECTS)]
            ;;
            ;;  1510: output (log/stderr1510) FAILED:
-           ;; --- log/check-expected   2015-06-27 07:45:53.166720834 +0000
-           ;; +++ log/check-generated  2015-06-27 07:45:53.166720834 +0000
+           ;; --- log/check-expected    2015-06-27 07:45:53.166720834 +0000
+           ;; +++ log/check-generated   2015-06-27 07:45:53.166720834 +0000
            ;; @@ -1,5 +1,5 @@
            ;;  * Connection #0 to host server1.example.com left intact[LF]
            ;;  * Connection #1 to host server2.example.com left intact[LF]