gnu: mrustc: Clean up.
[jackhill/guix/guix.git] / gnu / packages / freeipmi.scm
index a122f7e..57fe527 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix licenses)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module (gnu packages readline)
   #:use-module (gnu packages gnupg))
 
 (define-public freeipmi
   (package
     (name "freeipmi")
-    (version "1.3.2")
+    (version "1.6.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1gz2r3zp8ag4cd5cflh4fy8mpvwcx1wdr37mkqkph3m5lx2w48qb"))))
+               "0g0s4iwx0ng4rv7hp5cc3kkx4drahsc89981gwjblf04lfavppv5"))))
     (build-system gnu-build-system)
     (inputs
-     `(("readline" ,readline) ("libgcrypt" ,libgcrypt)))
-    (home-page "http://www.gnu.org/software/freeipmi/")
+     `(("libgcrypt" ,libgcrypt)))
+    (home-page "https://www.gnu.org/software/freeipmi/")
     (synopsis "Platform management, including sensor and power monitoring")
     (description
-     "GNU FreeIPMI provides in-band and out-of-band IPMI software based on the
-IPMI v1.5/2.0 specification.  The IPMI specification defines a set of
-interfaces for platform management and is implemented by a number vendors for
-system management.  The features of IPMI that most users will be interested in
-are sensor monitoring, system event monitoring, power control, and
-serial-over-LAN (SOL).  The FreeIPMI tools and libraries listed below should
-provide users with the ability to access and utilize these and many other
-features.  A number of useful features for large HPC or cluster environments
-have also been implemented into FreeIPMI.")
+     "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
+in accordance with the IPMI v1.5/2.0 specification.  These programs provide a
+set of interfaces for platform management.  Common functionality includes
+sensor monitoring, system event monitoring, power control and
+serial-over-LAN.")
     (license gpl3+)))