Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / ssh.scm
index e4a277c..112ccb3 100644 (file)
@@ -120,7 +120,7 @@ remote applications.")
                 #:phases (modify-phases %standard-phases
                            (add-before 'configure 'autoreconf
                              (lambda _
-                               (zero? (system* "autoreconf" "-v")))))))
+                               (invoke "autoreconf" "-v"))))))
    (native-inputs `(("autoconf" ,autoconf)
                     ("automake" ,automake)))
    (synopsis "Client-side C library implementing the SSH2 protocol")
@@ -187,17 +187,16 @@ a server that supports the SSH-2 protocol.")
         (replace 'install
          (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
            ;; install without host keys and system configuration files
-           (and (zero? (apply system* "make" "install-nosysconf" make-flags))
-                (begin
-                  (install-file "contrib/ssh-copy-id"
-                                (string-append (assoc-ref outputs "out")
-                                               "/bin/"))
-                  (chmod (string-append (assoc-ref outputs "out")
-                                        "/bin/ssh-copy-id") #o555)
-                  (install-file "contrib/ssh-copy-id.1"
-                                (string-append (assoc-ref outputs "out")
-                                               "/share/man/man1/"))
-                  #t)))))))
+           (apply invoke "make" "install-nosysconf" make-flags)
+           (install-file "contrib/ssh-copy-id"
+                         (string-append (assoc-ref outputs "out")
+                                        "/bin/"))
+           (chmod (string-append (assoc-ref outputs "out")
+                                 "/bin/ssh-copy-id") #o555)
+           (install-file "contrib/ssh-copy-id.1"
+                         (string-append (assoc-ref outputs "out")
+                                        "/share/man/man1/"))
+           #t)))))
    (synopsis "Client and server for the secure shell (ssh) protocol")
    (description
     "The SSH2 protocol implemented in OpenSSH is standardised by the
@@ -494,7 +493,8 @@ basis for almost any application.")
                     (("localhost") "127.0.0.1"))
 
                   (substitute* "src/testsuite/login-auth-test"
-                    (("/bin/cat") "cat"))))))
+                    (("/bin/cat") "cat"))
+                  #t))))
     (build-system gnu-build-system)
     (native-inputs
      `(("m4" ,m4)