gnu: http-parser: Update to 2.9.4-1.ec8b5ee [fixes CVE-2020-8287].
[jackhill/guix/guix.git] / gnu / packages / patches / glibc-supported-locales.patch
index 2888052..28577c7 100644 (file)
@@ -2,21 +2,20 @@ This patch is taken from debian's glibc package (generate-supported.mk).
 It install the localedata/SUPPORTED file of the glibc. This file lists
 all the supported locales of the glibc.
 
-diff --git a/localedata/Makefile.old b/localedata/Makefile
-index 34877c0..a61d9b9 100644
---- a/localedata/Makefile.old
+diff --git a/localedata/Makefile b/localedata/Makefile
+--- a/localedata/Makefile
 +++ b/localedata/Makefile
-@@ -91,7 +91,8 @@ endif
- # Files to install.
+@@ -176,7 +176,8 @@
+ else
  install-others := $(addprefix $(inst_i18ndir)/, \
                              $(addsuffix .gz, $(charmaps)) \
 -                            $(locales))
 +                            $(locales)) \
 +                   $(inst_i18ndir)/SUPPORTED
+ endif
  
  tests: $(objdir)/iconvdata/gconv-modules
-@@ -195,6 +196,14 @@ endif
+@@ -401,6 +402,14 @@
  
  include SUPPORTED
  
@@ -28,6 +27,6 @@ index 34877c0..a61d9b9 100644
 +      $(make-target-directory)
 +      $(INSTALL_DATA) LOCALES $@
 +
- INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
+ INSTALL-SUPPORTED-LOCALE-ARCHIVE=$(addprefix install-archive-, $(SUPPORTED-LOCALES))
+ INSTALL-SUPPORTED-LOCALE-FILES=$(addprefix install-files-, $(SUPPORTED-LOCALES))
  
- # Sometimes the whole collection of locale files should be installed.