gnu: python-psycopg2: Update to 2.8.6.
[jackhill/guix/guix.git] / gnu / packages / package-management.scm
index cc3a40c..ec87226 100644 (file)
@@ -14,6 +14,8 @@
 ;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
                         arch "-linux"
                         "/20131110/guile-2.0.9.tar.xz"))))
 
+;; NOTE: The commit IDs used here form a linked list threaded through the git
+;; history. In a phenomenon known as boot-stripping, not only the head of this
+;; list is used, but also a few older versions, when a guix from this package is
+;; used to build something also depending on guix.
+;;
+;; Therefore, if, by accident, you set this package to a non-existent commit ID,
+;; it is insufficient to simply correct it with the latest commit.
+;; Instead, please push one commit that rolls back Guix to before the mistake,
+;; and then another that points to the first one. That way, the faulty commit
+;; won't appear on the linked list.
 (define-public guix
   ;; Latest version of Guix, which may or may not correspond to a release.
   ;; Note: the 'update-guix-package.scm' script expects this definition to
   ;; start precisely like this.
   (let ((version "1.1.0")
-        (commit "ea924134f819eef072ba7df9080d39de97fd73e6")
-        (revision 6))
+        (commit "1c21468c7a7d09fbe065d1ceebf5f542537c877c")
+        (revision 27))
     (package
       (name "guix")
 
                       (commit commit)))
                 (sha256
                  (base32
-                  "08likdidf3k1zqf8821h6a84dsrvgbdhridhkzpjymc2c884j0w4"))
+                  "0bprn9inpqmc41ldcykl5pnybgz3slflrnb9pywfn3gsr4r48lbm"))
                 (file-name (string-append "guix-" version "-checkout"))))
       (build-system gnu-build-system)
       (arguments
@@ -277,6 +289,8 @@ $(prefix)/etc/init.d\n")))
                                (gcrypt (assoc-ref inputs "guile-gcrypt"))
                                (json   (assoc-ref inputs "guile-json"))
                                (sqlite (assoc-ref inputs "guile-sqlite3"))
+                               (zlib   (assoc-ref inputs "guile-zlib"))
+                               (lzlib  (assoc-ref inputs "guile-lzlib"))
                                (git    (assoc-ref inputs "guile-git"))
                                (bs     (assoc-ref inputs
                                                   "guile-bytestructures"))
@@ -284,7 +298,7 @@ $(prefix)/etc/init.d\n")))
                                (gnutls (assoc-ref inputs "gnutls"))
                                (locales (assoc-ref inputs "glibc-utf8-locales"))
                                (deps   (list gcrypt json sqlite gnutls
-                                             git bs ssh))
+                                             git bs ssh zlib lzlib))
                                (effective
                                 (read-line
                                  (open-pipe* OPEN_READ
@@ -319,11 +333,13 @@ $(prefix)/etc/init.d\n")))
 
                        ;; Guile libraries are needed here for
                        ;; cross-compilation.
-                       ("guile" ,guile-3.0)
+                       ("guile" ,guile-3.0-latest) ;for faster builds
                        ("gnutls" ,gnutls)
                        ("guile-gcrypt" ,guile-gcrypt)
                        ("guile-json" ,guile-json-4)
                        ("guile-sqlite3" ,guile-sqlite3)
+                       ("guile-zlib" ,guile-zlib)
+                       ("guile-lzlib" ,guile-lzlib)
                        ("guile-ssh" ,guile-ssh)
                        ("guile-git" ,guile-git)
 
@@ -340,13 +356,10 @@ $(prefix)/etc/init.d\n")))
       (inputs
        `(("bzip2" ,bzip2)
          ("gzip" ,gzip)
-         ("zlib" ,zlib)              ;for 'guix publish'
-         ("lzlib" ,lzlib)            ;for 'guix publish' and 'guix substitute'
-
          ("sqlite" ,sqlite)
          ("libgcrypt" ,libgcrypt)
 
-         ("guile" ,guile-3.0)
+         ("guile" ,guile-3.0-latest)
 
          ;; Some of the tests use "unshare" when it is available.
          ("util-linux" ,util-linux)
@@ -376,7 +389,9 @@ $(prefix)/etc/init.d\n")))
          ("guile-json" ,guile-json-4)
          ("guile-sqlite3" ,guile-sqlite3)
          ("guile-ssh" ,guile-ssh)
-         ("guile-git" ,guile-git)))
+         ("guile-git" ,guile-git)
+         ("guile-zlib" ,guile-zlib)
+         ("guile-lzlib" ,guile-lzlib)))
 
       (home-page "https://www.gnu.org/software/guix/")
       (synopsis "Functional package manager for installed software packages and versions")
@@ -486,9 +501,10 @@ the Nix package manager.")
    (package
      (inherit guix)
      (name "guix-minimal")
-     (inputs
-      `(("guile" ,guile-2.2)
-        ,@(alist-delete "guile" (package-inputs guix))))
+     (native-inputs
+      (fold alist-delete
+            (package-native-inputs guix)
+            '("guile-ssh")))
      (propagated-inputs
       (fold alist-delete
             (package-propagated-inputs guix)
@@ -542,15 +558,29 @@ out) and returning a package that uses that as its 'source'."
 (define-public nix
   (package
     (name "nix")
-    (version "2.3.5")
+    (version "2.3.7")
     (source (origin
              (method url-fetch)
              (uri (string-append "http://nixos.org/releases/nix/nix-"
                                  version "/nix-" version ".tar.xz"))
              (sha256
               (base32
-               "1hbqsrp1ii2sfq8x2mahjrl2182qck76n8blrl1jfz3xq99m6i15"))))
+               "15p50jkss6szinisb7axhxybgfi29sm9grz7mxwair8ljj2553yx"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--sysconfdir=/etc" "--enable-gc")
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'install
+           ;; Don't try & fail to create subdirectories in /etc, but keep them
+           ;; in the output as examples.
+           (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (etc (string-append out "/etc")))
+               (apply invoke "make" "install"
+                      (string-append "sysconfdir=" etc)
+                      (string-append "profiledir=" etc "/profile.d")
+                      make-flags)))))))
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("boost" ,boost)
               ("brotli" ,brotli)
@@ -711,10 +741,64 @@ environments.")
 (define-public python2-anaconda-client
   (package-with-python2 python-anaconda-client))
 
-(define-public python-conda
+(define-public python-conda-package-handling
+  (package
+    (name "python-conda-package-handling")
+    (version "1.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/conda/conda-package-handling/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0bqbs6a8jbjmbn47n5n1p529cx7pf4vgfnhqca9mflgidfb5i0jf"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'use-unmodified-libarchive
+           (lambda _
+             (substitute* "setup.py"
+               (("archive_and_deps") "archive"))
+             #t))
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest" "-vv" "tests"
+                     "-k"
+                     (string-append
+                      ;; TODO: these three fail because the mocker fixture
+                      ;; cannot be found
+                      "not test_rename_to_trash"
+                      " and not test_api_extract_tarball_with_libarchive_import_error"
+                      " and not test_delete_trash"
+                      ;; TODO: this one does not raise an exception when it
+                      ;; should.
+                      " and not test_secure_refusal_to_extract_abs_paths")))))))
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-tqdm" ,python-tqdm)))
+    (inputs
+     `(("libarchive" ,libarchive)))
+    (native-inputs
+     `(("python-cython" ,python-cython)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-mock" ,python-mock)))
+    (home-page "https://conda.io")
+    (synopsis "Create and extract conda packages of various formats")
+    (description
+     "This library is an abstraction of Conda package handling and a tool for
+extracting, creating, and converting between formats.")
+    (license license:bsd-3)))
+
+(define-public conda
   (package
-    (name "python-conda")
-    (version "4.3.16")
+    (name "conda")
+    (version "4.8.3")
     (source
      (origin
        (method git-fetch)
@@ -724,58 +808,118 @@ environments.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1qwy0awx4qf2pbk8z2b7q6wdcq7mvwpxxjhg27mbirdvs5hw7hb2"))))
+         "0iv1qzk21jsk6vdp3106xvpvl68zgfdqb3kyzpya87jhkl204l7r"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-permissions
+           (lambda _
+             ;; This file is no longer writable after downloading with
+             ;; 'git-fetch'
+             (make-file-writable
+              "tests/conda_env/support/saved-env/environment.yml")
+             #t))
+         (add-after 'unpack 'correct-python-executable-name
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((python (assoc-ref inputs "python-wrapper")))
+               #;
+               (substitute* "conda/common/path.py"
+                 (("python_version or ''")
+                  "python_version or '3'"))
+               (substitute* "conda/core/initialize.py"
+                 (("python_exe = join")
+                  (format #f "python_exe = \"~a/bin/python\" #"
+                          python))))
+             #t))
+         (add-after 'unpack 'do-not-use-python-root-as-prefix
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (python (assoc-ref inputs "python-wrapper")))
+               (substitute* "tests/core/test_initialize.py"
+                 (("\"\"\"\\) % conda_prefix")
+                  (format #f "\"\"\") % \"~a\"" python))
+                 (("CONDA_PYTHON_EXE \"%s\"' % join\\(conda_prefix")
+                  (format #f "CONDA_PYTHON_EXE \"%s\"' % join(\"~a\""
+                          python))
+                 (("conda_prefix = abspath\\(sys.prefix\\)")
+                  (format #f "conda_prefix = abspath(\"~a\")" out)))
+               (substitute* "conda/base/context.py"
+                 (("os.chdir\\(sys.prefix\\)")
+                  (format #f "os.chdir(\"~a\")" out))
+                 (("sys.prefix, '.condarc'")
+                  (format #f "\"~a\", '.condarc'" out))
+                 (("return abspath\\(sys.prefix\\)")
+                  (format #f "return abspath(\"~a\")" out))
+                 (("os.path.join\\(sys.prefix, bin_dir, exe\\)")
+                  (format #f "\"~a/bin/conda\"" out))
+                 (("'CONDA_EXE', sys.executable")
+                  (format #f "'CONDA_EXE', \"~a/bin/conda\"" out))))
+             #t))
          (add-before 'build 'create-version-file
            (lambda _
              (with-output-to-file "conda/.version"
                (lambda () (display ,version)))
              #t))
-         (add-before 'check 'remove-failing-tests
-           (lambda _
-             ;; These tests require internet/network access
-             (let ((network-tests '("test_cli.py"
-                                    "test_create.py"
-                                    "test_export.py"
-                                    "test_fetch.py"
-                                    "test_history.py"
-                                    "test_info.py"
-                                    "test_install.py"
-                                    "test_priority.py"
-                                    "conda_env/test_cli.py"
-                                    "conda_env/test_create.py"
-                                    "conda_env/specs/test_notebook.py"
-                                    "conda_env/utils/test_notebooks.py"
-                                    "core/test_index.py"
-                                    "core/test_repodata.py")))
-               (with-directory-excursion "tests"
-                 (for-each delete-file network-tests)
-
-                 ;; FIXME: This test creates a file, then deletes it and tests
-                 ;; that the file was deleted.  For some reason it fails when
-                 ;; building with guix, but does not when you run it in the
-                 ;; directory left when you build with the --keep-failed
-                 ;; option
-                 (delete-file "gateways/disk/test_delete.py")
-                 ;; This file is no longer writable after downloading with 'git-fetch'
-                 (make-file-writable "conda_env/support/saved-env/environment.yml")
-                 #t))))
          (replace 'check
            (lambda _
              (setenv "HOME" "/tmp")
-             (invoke "py.test"))))))
-    (native-inputs
-     `(("python-cytoolz" ,python-cytoolz)
-       ("python-ruamel.yaml" ,python-ruamel.yaml)
-       ("python-requests" ,python-requests)
+             (invoke "py.test" "-vv"
+                     "-k"
+                     (string-append
+                      "not integration"
+                      ;; This one reports a newer version of conda than
+                      ;; expected.
+                      " and not test_auto_update_conda"
+                      ;; This fails because the output directory is not a
+                      ;; Conda environment.
+                      " and not test_list"
+                      ;; This fails because we patched the default root
+                      ;; prefix.
+                      " and not test_default_target_is_root_prefix"
+                      ;; TODO: I don't understand what this failure means
+                      " and not test_PrefixData_return_value_contract"
+                      ;; TODO: same here
+                      " and not test_install_1"
+                      ;; Not sure if this is really wrong.  This fails because
+                      ;; /gnu/store/...python-conda-4.8.3/bin/python
+                      ;; is not /gnu/store/...python-wrapper-3.8.2/bin/python
+                      " and not test_make_entry_point"))))
+         (add-after 'install 'init
+           ;; This writes a whole bunch of shell initialization files to the
+           ;; prefix directory.  Many features of conda can only be used after
+           ;; running "conda init".
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (setenv "HOME" "/tmp")
+
+             ;; "conda init" insists on using sudo, because it is hell-bent on
+             ;; modifying system files.
+             (mkdir-p "/tmp/fake-sudo")
+             (with-output-to-file "/tmp/fake-sudo/sudo"
+               (lambda () (format #t "#!~/bin/sh~%exec $@" (which "sh"))))
+             (chmod "/tmp/fake-sudo/sudo" #o700)
+             (setenv "PATH" (string-append "/tmp/fake-sudo:"
+                                           (getenv "PATH")))
+
+             (invoke (string-append (assoc-ref outputs "out")
+                                    "/bin/conda")
+                     "init"))))))
+    (inputs
+     `(("python-wrapper" ,python-wrapper)))
+    (propagated-inputs
+     `(("python-anaconda-client" ,python-anaconda-client)
+       ("python-conda-package-handling" ,python-conda-package-handling)
+       ("python-cytoolz" ,python-cytoolz)
        ("python-pycosat" ,python-pycosat)
        ("python-pytest" ,python-pytest)
-       ("python-responses" ,python-responses)
        ("python-pyyaml" ,python-pyyaml)
-       ("python-anaconda-client" ,python-anaconda-client)))
+       ("python-requests" ,python-requests)
+       ("python-responses" ,python-responses)
+       ("python-ruamel.yaml" ,python-ruamel.yaml)
+       ("python-tqdm" ,python-tqdm)
+       ;; XXX: This is dragged in by libarchive and is needed at runtime.
+       ("zstd" ,zstd)))
     (home-page "https://github.com/conda/conda")
     (synopsis "Cross-platform, OS-agnostic, system-level binary package manager")
     (description
@@ -783,76 +927,11 @@ environments.")
 is the package manager used by Anaconda installations, but it may be used for
 other systems as well.  Conda makes environments first-class citizens, making
 it easy to create independent environments even for C libraries.  Conda is
-written entirely in Python.
-
-This package provides Conda as a library.")
+written entirely in Python.")
     (license license:bsd-3)))
 
-(define-public python2-conda
-  (let ((base (package-with-python2
-               (strip-python2-variant python-conda))))
-    (package (inherit base)
-             (native-inputs
-              `(("python2-enum34" ,python2-enum34)
-                ,@(package-native-inputs base))))))
-
-(define-public conda
-  (package (inherit python-conda)
-    (name "conda")
-    (arguments
-     (substitute-keyword-arguments (package-arguments python-conda)
-       ((#:phases phases)
-        `(modify-phases ,phases
-           (replace 'build
-             (lambda* (#:key outputs #:allow-other-keys)
-               ;; This test fails when run before installation.
-               (delete-file "tests/test_activate.py")
-
-               ;; Fix broken defaults
-               (substitute* "conda/base/context.py"
-                 (("return sys.prefix")
-                  (string-append "return \"" (assoc-ref outputs "out") "\""))
-                 (("return (prefix_is_writable\\(self.root_prefix\\))" _ match)
-                  (string-append "return False if self.root_prefix == self.conda_prefix else "
-                                 match)))
-
-               ;; The util/setup-testing.py is used to build conda in
-               ;; application form, rather than the default, library form.
-               ;; With this, we are able to run commands like `conda --help`
-               ;; directly on the command line
-               (invoke "python" "utils/setup-testing.py" "build_py")))
-           (replace 'install
-             (lambda* (#:key inputs outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out"))
-                      (target (string-append out "/lib/python"
-                                             (python-version
-                                              (assoc-ref inputs "python"))
-                                             "/site-packages/")))
-                 ;; The installer aborts if the target directory is not on
-                 ;; PYTHONPATH.
-                 (setenv "PYTHONPATH"
-                         (string-append target ":" (getenv "PYTHONPATH")))
-
-                 ;; And it aborts if the directory doesn't exist.
-                 (mkdir-p target)
-                 (invoke "python" "utils/setup-testing.py" "install"
-                         (string-append "--prefix=" out)))))
-           ;; The "activate" and "deactivate" scripts don't need wrapping.
-           ;; They also break when they are renamed.
-           (add-after 'wrap 'undo-wrap
-             (lambda* (#:key outputs #:allow-other-keys)
-               (with-directory-excursion (string-append (assoc-ref outputs "out") "/bin/")
-                 (delete-file "deactivate")
-                 (rename-file ".deactivate-real" "deactivate")
-                 (delete-file "activate")
-                 (rename-file ".activate-real" "activate")
-                 #t)))))))
-    (description
-     "Conda is a cross-platform, Python-agnostic binary package manager.  It
-is the package manager used by Anaconda installations, but it may be used for
-other systems as well.  Conda makes environments first-class citizens, making
-it easy to create independent environments even for C libraries.  Conda is
-written entirely in Python.")))
+(define-public python-conda
+  (deprecated-package "python-conda" conda))
 
 (define-public gwl
   (package
@@ -882,7 +961,7 @@ written entirely in Python.")))
        ("texinfo" ,texinfo)
        ("graphviz" ,graphviz)))
     (inputs
-     `(("guile" ,guile-3.0)))
+     `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))))
     (propagated-inputs
      `(("guix" ,guix)
        ("guile-commonmark" ,guile-commonmark)
@@ -921,6 +1000,15 @@ environments.")
                   (substitute* "configure.ac"
                     (("^GUILE_PKG.*")
                      "GUILE_PKG([3.0 2.2])\n"))
+
+                  ;; Avoid name clash and build failure now that
+                  ;; 'define-json-mapping' is also provided by Guile-JSON, as
+                  ;; of version 4.3.
+                  (substitute* (find-files "." "\\.scm$")
+                    (("define-json-mapping")
+                     "define-json-mapping*")
+                    (("<=>")
+                     "<->"))
                   #t))
               (file-name (string-append "guix-jupyter-" version "-checkout"))))
     (build-system gnu-build-system)
@@ -966,7 +1054,7 @@ environments.")
                          "-s")
                    "\",\n\t\t\""))
                  (("guix-jupyter-kernel.scm")
-                  (string-append out "/share/guile/site/2.2/"
+                  (string-append out "/share/guile/site/3.0/"
                                  "guix-jupyter-kernel.scm")))
                #t))))))
     (native-inputs
@@ -980,7 +1068,7 @@ environments.")
        ("python-ipykernel" ,python-ipykernel)))
     (inputs
      `(("guix" ,guix)
-       ("guile" ,guile-3.0)))
+       ("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))))
     (propagated-inputs
      `(("guile-json" ,guile-json-4)
        ("guile-simple-zmq" ,guile-simple-zmq)
@@ -997,14 +1085,14 @@ in an isolated environment, in separate namespaces.")
 (define-public gcab
   (package
     (name "gcab")
-    (version "1.2")
+    (version "1.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/gcab/"
                                   version "/gcab-" version ".tar.xz"))
               (sha256
                (base32
-                "038h5kk41si2hc9d9169rrlvp8xgsxq27kri7hv2vr39gvz9cbas"))))
+                "13q43iqld4l50yra45lhvkd376pn6qpk7rkx374zn8y9wsdzm9b7"))))
     (build-system meson-build-system)
     (native-inputs
      `(("glib:bin" ,glib "bin")         ; for glib-mkenums
@@ -1060,15 +1148,15 @@ for packaging and deployment of cross-compiled Windows applications.")
 (define-public libostree
   (package
     (name "libostree")
-    (version "2020.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/ostreedev/ostree/releases/download/v"
-                    (version-major+minor version) "/libostree-" version ".tar.xz"))
-              (sha256
-               (base32
-                "01cch4as23xspq6pck59al7x5jj60wl21g8p3iqbdxcjl1p3jxsq"))))
+    (version "2020.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/ostreedev/ostree/releases/download/v"
+             (version-major+minor version) "/libostree-" version ".tar.xz"))
+       (sha256
+        (base32 "0wk9fgj9jl25ns2hcgcb6j24k5mvfn13b02ka0p8l4hdh8c4hpc6"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -1114,15 +1202,14 @@ the boot loader configuration.")
 (define-public flatpak
   (package
    (name "flatpak")
-   (version "1.6.3")
+   (version "1.8.2")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "https://github.com/flatpak/flatpak/releases/download/"
                          version "/flatpak-" version ".tar.xz"))
      (sha256
-      (base32
-       "17s8nqdxd4xdy7ag9bw06adxccha78jmlsa3zpqnl3qh92pg0hji"))))
+      (base32 "1c45a0k7wx685n5b3ihv7dk0mm2kmwbw7cx8w5g2la62yxfn49kr"))))
 
    ;; Wrap 'flatpak' so that GIO_EXTRA_MODULES is set, thereby allowing GIO to
    ;; find the TLS backend in glib-networking.
@@ -1137,7 +1224,9 @@ the boot loader configuration.")
        (string-append "--with-system-bubblewrap="
                       (assoc-ref %build-inputs "bubblewrap")
                       "/bin/bwrap")
-       "--with-system-dbus-proxy")
+       (string-append "--with-system-dbus-proxy="
+                      (assoc-ref %build-inputs "xdg-dbus-proxy")
+                      "/bin/xdg-dbus-proxy"))
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'fix-tests
@@ -1156,7 +1245,7 @@ cp -r /tmp/locale/*/en_US.*")))
               (("/usr/bin/python3") (which "python3")))
             #t))
         ;; Many tests fail for unknown reasons, so we just run a few basic
-        ;; tests
+        ;; tests.
         (replace 'check
           (lambda _
             (setenv "HOME" "/tmp")
@@ -1172,6 +1261,7 @@ cp -r /tmp/locale/*/en_US.*")))
       ("libcap" ,libcap)
       ("pkg-config" ,pkg-config)
       ("python" ,python)
+      ("python-pyparsing" ,python-pyparsing)
       ("socat" ,socat)
       ("which" ,which)))
    (propagated-inputs `(("glib-networking" ,glib-networking)
@@ -1200,3 +1290,53 @@ applications")
    (description "Flatpak is a system for building, distributing, and running
 sandboxed desktop applications on GNU/Linux.")
    (license license:lgpl2.1+)))
+
+(define-public akku
+  (package
+    (name "akku")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/akkuscm/akku.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256 (base32 "1dm32ws3nshnnscd7k75zswxxs1pp25y2q4k8j5ms241hz47by3c"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'bootstrap
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (for-each patch-shebang
+                                '("bootstrap"
+                                  ".akku/env"))
+                      (let* ((home "/tmp")
+                             (datadir (string-append home "/.local/share/akku/")))
+                        (mkdir-p datadir)
+                        (invoke "touch" (string-append datadir "index.db"))
+                        (setenv "HOME" home))
+                      (invoke "./bootstrap")
+                      #t))
+                  (add-after 'install 'wrap-executables
+                    (lambda* (#:key outputs inputs #:allow-other-keys)
+                      (let ((out (assoc-ref outputs "out"))
+                            (curl (assoc-ref inputs "curl")))
+                        (wrap-program (string-append out "/bin/akku")
+                          `("LD_LIBRARY_PATH" ":" prefix (,(string-append curl "/lib"))))
+                        #t))))))
+    (native-inputs
+     `(("which" ,which)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("guile" ,guile-3.0)
+       ("curl" ,curl)))
+    (home-page "https://akkuscm.org/")
+    (synopsis "Language package manager for Scheme")
+    (description
+     "Akku.scm is a project-based language package manager for R6RS and R7RS Scheme.
+It is mainly meant for programmers who develop portable programs or libraries in Scheme,
+but could potentially work for end-users of those programs.  It also has a translator
+from R7RS, which allows most R7RS code to run on R6RS implementations.")
+    (license license:gpl3+)))