gnu: Adjust formatting as recommended by 'guix lint'.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
index c13af20..97e7d38 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
+;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (gnu packages image)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
-  #:use-module (gnu packages openssl)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages photo)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages valgrind)
   #:use-module (gnu packages video)
   #:use-module (gnu packages xorg))
 (define-public efl
   (package
     (name "efl")
-    (version "1.14.2")
+    (version "1.15.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "http://download.enlightenment.org/rel/libs/efl/efl-"
+                    "https://download.enlightenment.org/rel/libs/efl/efl-"
                     version ".tar.xz"))
               (sha256
-               (base32 "0kg51v63ljq1z4dj65aiyxaqhq54gkl4hx53ifwbci6ihammandr"))))
+               (base32
+                "1962wqx7gdnpzvnkbighyn4hj5vw8l4c1d7xl5zilqjlyhcqywyx"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
 for Enlightenment.  Libraries covers data serialization, wide support for
 graphics rendering, UI layout and themes, interaction with OS, access to
 removable devices or support for multimedia.")
-    (license (list license:bsd-2 license:lgpl2.1 license:zlib)))) ; different parts under different licenses
+    ;; Different parts are under different licenses.
+    (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
 
 (define-public elementary
   (package
     (name "elementary")
-    (version "1.14.2")
+    (version "1.15.2")
     (source (origin
               (method url-fetch)
               (uri
-               (string-append
-                "http://download.enlightenment.org/rel/libs/elementary/elementary-"
-                version ".tar.xz"))
+               (string-append "https://download.enlightenment.org/rel/libs/"
+                              "elementary/elementary-" version ".tar.xz"))
               (sha256
-               (base32 "1ck1jm9dfx2l72nklndqjfsxjqb0024b88naskld1dk9b8drs76b"))))
+               (base32
+                "0gqg98bglnl2jggdzxzrh9r7bv32i4sahspms0bihq8b45rk0g2j"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -156,7 +159,7 @@ full capabilities of EFL.")
 (define-public evas-generic-loaders
   (package
     (name "evas-generic-loaders")
-    (version "1.14.0")
+    (version "1.15.0")
     (source (origin
               (method url-fetch)
               (uri
@@ -165,7 +168,8 @@ full capabilities of EFL.")
                 "evas_generic_loaders/evas_generic_loaders-"
                 version ".tar.xz"))
               (sha256
-               (base32 "18b6xmbf81bly4mlwlzwr17g2m8dzznbhsdjk6pbb3nw4wn3y88l"))))
+               (base32
+                "0zzx06j20x580xqnnsxp7gb7rv279zcgvdxfbhs905af9m6rwlqy"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -187,15 +191,16 @@ files in Evas (EFL canvas library).")
 (define-public emotion-generic-players
   (package
     (name "emotion-generic-players")
-    (version "1.14.0")
+    (version "1.15.0")
     (source (origin
               (method url-fetch)
               (uri
-               (string-append
-                "http://download.enlightenment.org/rel/libs/emotion_generic_players/emotion_generic_players-"
-                version ".tar.xz"))
+               (string-append "https://download.enlightenment.org/rel/libs/"
+                              "emotion_generic_players/emotion_generic_players"
+                              "-" version ".tar.xz"))
               (sha256
-               (base32 "0685jzag98ykknycfdqn70zif3fmcfi6m8k9yp6d79r1h8gc49n4"))))
+               (base32
+                "0pszwmcygxnv1sfx0m79md2jmi4sng8mdb1xcr6h2z5c8685wvcz"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -213,15 +218,15 @@ The only supported now is VLC.")
 (define-public terminology
   (package
     (name "terminology")
-    (version "0.8.0")
+    (version "0.9.1")
     (source (origin
               (method url-fetch)
               (uri
-               (string-append
-                "http://download.enlightenment.org/rel/apps/terminology/terminology-"
-                version ".tar.gz"))
+               (string-append "https://download.enlightenment.org/rel/apps/"
+                              "terminology/terminology-" version ".tar.xz"))
               (sha256
-               (base32 "0a767ixackzmhb2awrhjy7q6vsivsd54wc434i617xiw095x843s"))))
+               (base32
+                "1kwv9vkhngdm5v38q93xpcykghnyawhjjcb5bgy0p89gpbk7mvpc"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -237,18 +242,43 @@ URL and local path detection, themes, popup based content viewer for non-text
 contents and more.")
     (license license:bsd-2)))
 
-(define-public enlightenment
+(define-public rage
   (package
-    (name "enlightenment")
-    (version "0.19.4")
+    (name "rage")
+    (version "0.1.4")
     (source (origin
               (method url-fetch)
               (uri
                (string-append
-                "http://download.enlightenment.org/rel/apps/enlightenment/enlightenment-"
+                "https://download.enlightenment.org/rel/apps/rage/rage-"
                 version ".tar.gz"))
               (sha256
-               (base32 "01pg3ng4m3vmwzzivlssdmvhf72bsvcmm3xwf45849cibllaib8v"))))
+               (base32 "10j3n8crk16jzqz2hn5djx6vms5f6x83qyiaphhqx94h9dgv2mgg"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("efl" ,efl)
+       ("elementary" ,elementary)))
+    (home-page "https://www.enlightenment.org/about-rage")
+    (synopsis "Video and audio player based on EFL")
+    (description
+     "Rage is a video and audio player written with Enlightenment Foundation
+Libraries with some extra bells and whistles.")
+    (license license:bsd-2)))
+
+(define-public enlightenment
+  (package
+    (name "enlightenment")
+    (version "0.19.12")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "https://download.enlightenment.org/rel/apps/"
+                              name "/" name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                 "098bdx9qmv1yqqwfydrzs7fvbnhsf3vaib9pmqsyg4ihgqrkrwjm"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))