gnu: r-shape: Update to 1.4.5.
[jackhill/guix/guix.git] / gnu / packages / kde-utils.scm
index 699f1a9..5e6a872 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages kde)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages kde-plasma)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages samba)
   #:use-module (gnu packages xorg))
 
 (define-public kate
   (package
     (name "kate")
-    (version "19.08.3")
+    (version "20.04.1")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://kde/stable/applications/" version
+       (uri (string-append "mirror://kde/stable/release-service/" version
                            "/src/kate-" version ".tar.xz"))
        (sha256
-        (base32 "0wgcw10c4grkmsyp79ashwgpy59lgrinwdib4mjclpw2grp0g7xb"))))
-    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+        (base32 "0nrby307syrqlxrf9lwdzc9c15ifw47418qwszqwg345ma2pww7i"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -100,15 +103,14 @@ Kate's features include:
 (define-public kmag
   (package
     (name "kmag")
-    (version "19.08.3")
+    (version "20.04.1")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://kde/stable/applications/" version
+      (uri (string-append "mirror://kde/stable/release-service/" version
                           "/src/kmag-" version ".tar.xz"))
       (sha256
-       (base32 "0l69mgnh2mmkxawwibqdx9n7myl6qqnr2fd3mpsg2bzpcfvmsvi1"))))
-    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+       (base32 "18lk8i2r90gvw8q5j179xgpniih92mwk06krk7w4jv98yinqf6m5"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -132,15 +134,14 @@ artists to web-designers to people with low vision.")
 (define-public kmousetool
   (package
     (name "kmousetool")
-    (version "19.08.3")
+    (version "20.04.1")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://kde/stable/applications/" version
+       (uri (string-append "mirror://kde/stable/release-service/" version
                            "/src/kmousetool-" version ".tar.xz"))
        (sha256
-        (base32 "169kk20mkm29nycg2vs1k5cs22gzchqs9hbfd661cy2l7n4d8d04"))))
-    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+        (base32 "01j6bx8zihns4ip8maj0gb3w3bhx1ha2ljhfmsm6lcyay531ay98"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -172,15 +173,14 @@ whom pressing buttons hurts.")
 (define-public kmouth
   (package
     (name "kmouth")
-    (version "19.08.3")
+    (version "20.04.1")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://kde/stable/applications/" version
+       (uri (string-append "mirror://kde/stable/release-service/" version
                            "/src/kmouth-" version ".tar.xz"))
        (sha256
-        (base32 "1agjxf1jfi967hj1iz788n6cna6fr7qg80zsx6s119hg7b0xwqmr"))))
-    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+        (base32 "1afgxlys9mvmc3rd33g7gchfb0ylx83x3x0a0qf3dra6cpgsgcg7"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -221,7 +221,6 @@ sentences to be re-spoken.")
                            "/src/kronometer-" version ".tar.xz"))
        (sha256
         (base32 "05hs8729a3aqjpwmn2xdf2sriacrll4sj4ax3lm4s1ravj09n9bm"))))
-    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -237,14 +236,6 @@ sentences to be re-spoken.")
        ("kxmlgui" ,kxmlgui)
        ("oxygen-icons" ,oxygen-icons) ;; default icon set
        ("qtbase" ,qtbase)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'check-setup
-           (lambda _
-             ;; make Qt render "offscreen", required for tests
-             (setenv "QT_QPA_PLATFORM" "offscreen")
-             #t)))))
     (home-page "https://kde.org/applications/utilities/org.kde.kronometer")
     (synopsis "Simple stopwatch application")
     (description "Kronometer is a stopwatch application.  It features the
@@ -264,7 +255,6 @@ to save the times and resume them later.")
                            "/krusader-" version ".tar.xz"))
        (sha256
         (base32 "02b1jz5a7cjr13v6c7fczrhs1xmg1krnva5fxk8x2bf4nd1rm8s1"))))
-    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -309,6 +299,34 @@ Almost completely customizable, Krusader is very user friendly, fast and looks
 great on your desktop.")
     (license license:gpl2+)))
 
+(define-public kxstitch
+  (package
+    (name "kxstitch")
+    (version "2.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/kxstitch/" version
+                           "/kxstitch-" version ".tar.xz"))
+       (sha256
+        (base32 "1q6blvcqz6hxdfrkdi0fplmz7rmk3im56kpp68r0yrivhx3hn8sc"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("ktexteditor" ,ktexteditor)
+       ("imagemagick" ,imagemagick)
+       ("qtbase" ,qtbase)
+       ("qtx11extras" ,qtx11extras)))
+    (home-page "https://kde.org/applications/en/graphics/org.kde.kxstitch")
+    (synopsis "Create and print cross stitch patterns")
+    (description
+     "KXStitch allows creating and printing cross stitch patterns, which can
+either be created or generated from a image.")
+    (license license:gpl2+)))
+
 (define-public okteta
   (package
     (name "okteta")
@@ -321,7 +339,6 @@ great on your desktop.")
                            "/src/okteta-" version ".tar.xz"))
        (sha256
         (base32 "03wsv83l1cay2dpcsksad124wzan7kh8zxdw1h0yicn398kdbck4"))))
-    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -384,7 +401,6 @@ redone.")
                            "rsibreak-" version ".tar.xz"))
        (sha256
         (base32 "09axg6gbmpnxsk88mdjbxxvfaj5af7xaf1gmnr17b0506zcfgwhv"))))
-    (properties `((tags . ("Desktop" "KDE" "Utilities"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -406,14 +422,6 @@ redone.")
        ("kxmlgui" ,kxmlgui)
        ("oxygen-icons" ,oxygen-icons) ;; default icon set
        ("qtbase" ,qtbase)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'check-setup
-           (lambda _
-             ;; make Qt render "offscreen", required for tests
-             (setenv "QT_QPA_PLATFORM" "offscreen")
-             #t)))))
     (home-page "https://kde.org/applications/utilities/org.kde.rsibreak")
     (synopsis "Assists in the Recovery and Prevention of Repetitive Strain
 Injury")
@@ -422,3 +430,113 @@ result of working with a mouse and keyboard.  This utility can be used to
 remind you to take a break now and then.")
     (license ;; GPL for programs, FDL for documentation
      (list license:gpl2+ license:fdl1.2+))))
+
+(define-public smb4k
+  (package
+    (name "smb4k")
+    (version "3.0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://sourceforge.net/projects/smb4k/files/"
+                           version "/smb4k-" version ".tar.xz/download"))
+       (sha256
+        (base32 "0hz6nfd845bykf78s4g2qs77szl96gy6g8rpg44pqd39a0k0xbh7"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("kauth" ,kauth)
+       ("kconfig" ,kconfig)
+       ("kconfigwidgets" ,kconfigwidgets)
+       ("kcompletion" ,kcompletion)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kcrash" ,kcrash)
+       ("kdbusaddons" ,kdbusaddons)
+       ("ki18n" ,ki18n)
+       ("kiconthemes" ,kiconthemes)
+       ("kio" ,kio)
+       ("kjobwidgets" ,kjobwidgets)
+       ("knotifications" ,knotifications)
+       ("knotifyconfig" ,knotifyconfig)
+       ("ktextwidgets" ,ktextwidgets)
+       ("kwallet" ,kwallet)
+       ("kwidgetsaddons" ,kwidgetsaddons)
+       ("kwindowsystem" ,kwindowsystem)
+       ("kxmlgui" ,kxmlgui)
+       ("libsmbclient" ,samba)
+       ("oxygen-icons" ,oxygen-icons) ;; default icon set
+       ("plasma-framework" ,plasma-framework)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
+       ("solid" ,solid)))
+    (home-page "https://kde.org/applications/utilities/org.kde.smb4k")
+    (synopsis "Samba (SMB) share advanced browser")
+    (description "Smb4K is an network neighborhood browser for the KDE
+Software Compilation and a frontend to the programs of the Samba software
+suite.
+
+Features:
+@itemize
+@item Scanning for (active) workgroups, hosts, and shares
+@item Support of the CIFS (Linux) and SMBFS (FreeBSD) file system
+@item Mounting and unmounting of shares (using the KAuth framework)
+@item Access to the files of a mounted share using a file manager or terminal
+@item Auto-detection of external mounts and unmounts
+@item Remounting of previously used shares on program start
+@item Miscellaneous infos about remote network items and mounted shares
+@item Network search
+@item WINS server support
+@item Preview of the contents of a share
+@item Several methods to look up the initial list of workgroups and domains
+@item Default login
+@item Special handling of homes shares
+@item Ability to bookmark favorite shares and organize them in groups
+@item System tray widget
+@item Support of advanced Samba options
+@item Support of printer shares
+@item KWallet support
+@item Synchronization of a remote share with a local copy and vice versa
+@item Ability to define custom options for individual servers and shares
+@item Laptop support through the Solid hardware device framework
+@end itemize")
+    (license license:gpl2+)))
+
+(define-public sweeper
+  (package
+    (name "sweeper")
+    (version "20.04.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/sweeper-" version ".tar.xz"))
+       (sha256
+        (base32 "1az3c2khnh51bbmqpamj4p26d3a0ff4l5rd3vcrylg94mk7wgh59"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("kactivities-stats" ,kactivities-stats)
+       ("kbookmarks" ,kbookmarks)
+       ("kcrash" ,kcrash)
+       ("kconfig" ,kconfig)
+       ("kconfigwidgets" ,kconfigwidgets)
+       ("kcoreaddons" ,kcoreaddons)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("ktextwidgets" ,ktextwidgets)
+       ("kxmlgui" ,kxmlgui)
+       ("oxygen-icons" ,oxygen-icons) ;; default icon set
+       ("qtbase" ,qtbase)))
+    (home-page "https://kde.org/applications/utilities/org.kde.sweeper")
+    (synopsis "Temporary file and history cleaner")
+    (description "
+Sweeper helps to clean unwanted traces the user leaves on the system and to
+regain disk space removing unused temporary files.
+It can quickly remove temporary information, such as web page cookies,
+browser history, or the list of recently-opened documents.  It helps provide
+additional privacy on a system shared between multiple users.")
+    (license license:lgpl2.0+ )))