gnu: Add texlive-todonotes.
[jackhill/guix/guix.git] / gnu / packages / lighting.scm
index 5f816dc..4718795 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
+;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages lighting)
   #:use-module (guix build-system gnu)
-  #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages protobuf))
 
 (define-public ola
-  (package
-    (name "ola")
-    (version "0.10.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/OpenLightingProject/ola/releases/download/"
-                    version "/ola-" version ".tar.gz"))
-              (patches (search-patches "ola-readdir-r.patch"))
-              (sha256
-               (base32
-                "1yf1yy9n64n73zjq2bwc0gik0dd3n05297hdrrma2qvb0imzm5h1"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     `(("bison" ,bison)
-       ("cppunit" ,cppunit)
-       ("flex" ,flex)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("libftdi" ,libftdi)
-       ("libmicrohttpd" ,libmicrohttpd)
-       ("libusb" ,libusb)
-       ("libuuid" ,util-linux)
-       ("zlib" ,zlib)))
-    (propagated-inputs
-     `(("protobuf" ,protobuf))) ;; for pkg-config --libs libola
-    (arguments
-     `(;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
-       ;; build to fail on low memory systems.  We disable that with the
-       ;; following configure flags.
-       #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
-    (synopsis "Framework for controlling entertainment lighting equipment")
-    (description "The Open Lighting Architecture is a framework for lighting
+  ;; Use a commit that allows building with libmicrohttpd 0.9.71.
+  ;; https://github.com/OpenLightingProject/ola/pull/1651
+  (let ((commit "5d882936436240b312b3836afd199587beaca840")
+        (revision "0"))
+    (package
+      (name "ola")
+      (version (git-version "0.10.7" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/OpenLightingProject/ola")
+               (commit commit)))
+         (sha256
+          (base32 "1bhl3gvmvmnyrygfj13cibf2xirm285m8abjkaxq22hrqbsvab2m"))
+         (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("bison" ,bison)
+         ("cppunit" ,cppunit)
+         ("flex" ,flex)
+         ("pkg-config" ,pkg-config)
+
+         ;; For git repository bootstrapping.
+         ("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("libtool" ,libtool)))
+      (inputs
+       `(("libftdi" ,libftdi)
+         ("libmicrohttpd" ,libmicrohttpd)
+         ("libusb" ,libusb)
+         ("libuuid" ,util-linux "lib")
+         ("zlib" ,zlib)))
+      (propagated-inputs
+       `(("protobuf" ,protobuf)))       ; for pkg-config --libs libola
+      (arguments
+       `( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
+         ;; build to fail on low memory systems.  We disable that with the
+         ;; following configure flags.
+         #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
+      (synopsis "Framework for controlling entertainment lighting equipment")
+      (description "The Open Lighting Architecture is a framework for lighting
 control information.  It supports a range of protocols and over a dozen USB
 devices.  It can run as a standalone service, which is useful for converting
 signals between protocols, or alternatively using the OLA API, it can be used
 as the backend for lighting control software.  OLA runs on many different
 platforms including ARM, which makes it a perfect fit for low cost Ethernet to
 DMX gateways.")
-    (home-page "https://www.openlighting.org/ola")
-    (license license:lgpl2.1+)))
+      (home-page "https://www.openlighting.org/ola")
+      (license license:lgpl2.1+))))