Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / avahi.scm
index df74437..8a01272 100644 (file)
@@ -24,7 +24,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
-  #:use-module (gnu packages databases)
+  #:use-module (gnu packages dbm)
   #:use-module (gnu packages libdaemon)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pkg-config)
@@ -35,7 +35,7 @@
   (package
     (name "avahi")
     (version "0.7")
-    (home-page "http://avahi.org")
+    (home-page "https://avahi.org")
     (source (origin
              (method url-fetch)
              (uri (string-append home-page "/download/avahi-"
              (sha256
               (base32
                "0128n7jlshw4bpx0vg8lwj8qwdisjxi7mvniwfafgnkzzrfrpaap"))
-             (patches (search-patches "avahi-localstatedir.patch"))))
+             (patches (search-patches "avahi-localstatedir.patch"
+                                      "avahi-CVE-2018-1000845.patch"))))
+    ;; Hide a duplicate of the CVE fixed above.
+    (properties `((lint-hidden-cve . ("CVE-2017-6519"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("--with-distro=none"