Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / ebook.scm
index f62456f..2b450ca 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages xorg))
 
 (define-public chmlib
@@ -49,7 +51,7 @@
              (sha256
                (base32
                 "18zzb4x3z0d7fjh1x5439bs62dmgsi4c1pg3qyr7h5gp1i5xcj9l"))
-             (patches (list (search-patch "chmlib-inttypes.patch")))))
+             (patches (search-patches "chmlib-inttypes.patch"))))
     (build-system gnu-build-system)
     (home-page "http://www.jedrea.com/chmlib/")
     (synopsis "Library for CHM files")
@@ -59,7 +61,7 @@
 (define-public calibre
   (package
     (name "calibre")
-    (version "2.28.0")
+    (version "2.58.0")
     (source
       (origin
         (method url-fetch)
@@ -67,8 +69,8 @@
                             version "/calibre-"
                             version ".tar.xz"))
         (sha256
-          (base32
-           "15sb74v0nlj45fhlnw1afll35l90cxw78s15fb2nx3fih7ahv3cf"))
+         (base32
+          "0npqvfjqj1vwa7nmnsyd4d30z40brydw275ldf1jankrp6dr9dyd"))
         ;; Remove non-free or doubtful code, see
         ;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
         (modules '((guix build utils)))
@@ -76,8 +78,8 @@
           '(begin
             (delete-file-recursively "src/unrar")
             (delete-file "src/odf/thumbnail.py")))
-        (patches (list (search-patch "calibre-drop-unrar.patch")
-                       (search-patch "calibre-no-updates-dialog.patch")))))
+        (patches (search-patches "calibre-drop-unrar.patch"
+                                 "calibre-no-updates-dialog.patch"))))
     (build-system python-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("libpng" ,libpng)
        ("libusb" ,libusb)
        ("libxrender" ,libxrender)
+       ("openssl" ,openssl)
        ("podofo" ,podofo)
        ("python" ,python-2)
        ("python2-apsw" ,python2-apsw)