tests: hackage: Fix mock urls.
[jackhill/guix/guix.git] / gnu / packages / openldap.scm
index fe7961a..4bbc6a6 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,7 +26,7 @@
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages icu4c)
-  #:use-module (gnu packages openssl)
+  #:use-module (gnu packages tls)
   #:use-module ((guix licenses) #:select (openldap2.8))
   #:use-module (guix packages)
   #:use-module (guix download)
 (define-public openldap
   (package
    (name "openldap")
-   (version "2.4.40")
+   (version "2.4.44")
    (source (origin
             (method url-fetch)
-            (uri (string-append
-                   "ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/openldap-"
-                   version ".tgz"))
-            (sha256 (base32
-                     "1nyslrgwxwilgv5sixc37svls5rbvhsv9drb7hlrjr2vqaji29ni"))))
+
+            ;; See <http://www.openldap.org/software/download/> for a list of
+            ;; mirrors.
+            (uri (list (string-append
+                        "ftp://mirror.switch.ch/mirror/OpenLDAP/"
+                        "openldap-release/openldap-" version ".tgz")
+                       (string-append
+                        "ftp://ftp.OpenLDAP.org/pub/OpenLDAP/"
+                        "openldap-release/openldap-" version ".tgz")
+                       (string-append
+                        "ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/"
+                        "openldap-release/openldap-" version ".tgz")))
+            (sha256
+             (base32
+              "0044p20hx07fwgw2mbwj1fkx04615hhs1qyx4mawj2bhqvrnppnp"))))
    (build-system gnu-build-system)
-   (inputs `(("bdb" ,bdb)
+   (inputs `(("bdb" ,bdb-5.3)
              ("openssl" ,openssl)
              ("cyrus-sasl" ,cyrus-sasl)
              ("groff" ,groff)