gnu: gawk: Remove unneeded 'install-locale' phase.
[jackhill/guix/guix.git] / gnu / packages / gawk.scm
index 425974f..6bfea34 100644 (file)
                                (string-append "### " match))))
                           '())))
 
-                (alist-cons-before
-                 'check 'install-locales
-                 (lambda _
-                   ;; A bunch of tests require the availability of a UTF-8
-                   ;; locale and otherwise fail.  Since UTF-8 locales are not
-                   ;; available during bootstrap, create one here.
-                   (setenv "GUIX_LOCPATH" (getcwd))
-                   (zero? (system* "localedef" "--no-archive"
-                                   "--prefix" (getcwd) "-i" "en_US"
-                                   "-f" "UTF-8" "./en_US.utf8")))
-                 %standard-phases))))
+                %standard-phases)))
    (inputs `(("libsigsegv" ,libsigsegv)
 
              ,@(if (%current-target-system)