gnu: Add libusbmuxd.
[jackhill/guix/guix.git] / gnu / packages / scheme.scm
index 926169c..b836447 100644 (file)
@@ -10,6 +10,7 @@
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
+;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libunistring)
   #:use-module (gnu packages m4)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pcre)
-  #:use-module (gnu packages databases)
   #:use-module (gnu packages emacs)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages netpbm)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages image)
   #:use-module (gnu packages xorg)
+  #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages libedit)
+  #:use-module (srfi srfi-1)
   #:use-module (ice-9 match))
 
 (define (mit-scheme-source-directory system version)
 (define-public mit-scheme
   (package
     (name "mit-scheme")
-    (version "9.2")
+    (version "10.1.3")
     (source #f)                                   ; see below
     (outputs '("out" "doc"))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                                ; no "check" target
-       #:modules ((guix build gnu-build-system)
+     `(#:modules ((guix build gnu-build-system)
                   (guix build utils)
                   (srfi srfi-1))
        #:phases
              ;; Delete these dangling symlinks since they break
              ;; `patch-shebangs'.
              (for-each delete-file
-                       (append '("src/lib/shim-config.scm")
-                               (find-files "src/lib/lib" "\\.so$")
-                               (find-files "src/lib" "^liarc-")
-                               (find-files "src/compiler" "^make\\.")))
+                       (find-files "src/compiler" "^make\\."))
              (chdir "src")
              #t))
+         (add-after 'unpack 'patch-/bin/sh
+           (lambda _
+             (setenv "CONFIG_SHELL" (which "sh"))
+             (substitute* '("../tests/ffi/autogen.sh"
+                            "../tests/ffi/autobuild.sh"
+                            "../tests/ffi/test-ffi.sh"
+                            "../tests/runtime/test-process.scm"
+                            "runtime/unxprm.scm")
+               (("/bin/sh") (which "sh"))
+               (("\\./autogen\\.sh")
+                (string-append (which "sh") " autogen.sh"))
+               (("\\./configure")
+                (string-append (which "sh") " configure")))
+             #t))
          ;; FIXME: the texlive-union insists on regenerating fonts.  It stores
          ;; them in HOME, so it needs to be writeable.
          (add-before 'build 'set-HOME
                  (invoke bin/sh "./configure"
                          (string-append "--prefix=" out)
                          (string-append "SHELL=" bin/sh))
-                 (substitute* '("Makefile" "make-common")
-                   (("/lib/mit-scheme/doc")
-                    (string-append "/share/doc/" ,name "-" ,version)))
                  #t))))
          (add-after 'build 'build-doc
            (lambda* _
                (with-directory-excursion "../doc"
                  (for-each (lambda (target)
                              (invoke "make" target))
-                           '("install-config" "install-info-gz" "install-man"
+                           '("install-info-gz" "install-man"
                              "install-html" "install-pdf")))
                (mkdir-p new-doc/mit-scheme-dir)
                (copy-recursively
-                (string-append old-doc-dir "/" ,name "-" ,version)
+                (string-append old-doc-dir "/" ,name)
                 new-doc/mit-scheme-dir)
                (delete-file-recursively old-doc-dir)
                #t))))))
     (native-inputs
-     `(("texlive" ,(texlive-union (list texlive-tex-texinfo)))
+     `(;; Autoconf, Automake, and Libtool are necessary for the FFI tests.
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("texlive" ,(texlive-union (list texlive-tex-texinfo)))
        ("texinfo" ,texinfo)
        ("m4" ,m4)))
     (inputs
            (match (%current-system)
              ("x86_64-linux"
               (base32
-               "1skzxxhr0iq96bf0j5m7mvf3i4sppfyfa6gpqn34mwgkw1fx8274"))
+               "03m7cc035w3avs91j2pcz9f15ssgvgp3rm045d1vbydqrkzfyw8k"))
              ("i686-linux"
               (base32
-               "1fmlpnhf5a75db93phajh4ysbdgrgl72v45lk3kznriprl0a7jc6"))
+               "05sjyz90xxfnmi87qv8x0yx0fcallnzl1dciygdafp317pn489is"))
              (_
-              (base32
-               "0w5ib5vsidihb4hb6fma3sp596ykr8izagm57axvgd6lqzwicsjg"))))))))
+               (base32
+                ""))))))))
 
     ;; Fails to build on MIPS, see <http://bugs.gnu.org/18221>.
-    (supported-systems '("x86_64-linux" "i686-linux" "armhf-linux"))
+    ;; Also, the portable C version of MIT/GNU Scheme did not work in time for
+    ;; release in version 10.1.
+    (supported-systems '("x86_64-linux" "i686-linux"))
 
     (home-page "https://www.gnu.org/software/mit-scheme/")
     (synopsis "A Scheme implementation with integrated editor and debugger")
@@ -205,110 +222,114 @@ features an integrated Emacs-like editor and a large runtime library.")
     (properties '((ftp-directory . "/gnu/mit-scheme/stable.pkg")))))
 
 (define-public bigloo
-  (package
-    (name "bigloo")
-    (version "4.3b")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Bigloo/bigloo"
-                                 version ".tar.gz"))
-             (sha256
-              (base32
-               "1x7xdgsls277zlf6gcaxs2cj62xj6yvb0qxh0ddmxfamvxba0cf4"))
-             ;; Remove bundled libraries.
-             (modules '((guix build utils)))
-             (snippet
-              '(begin
-                 (for-each delete-file-recursively
-                           '("gc" "gmp" "libuv"))
-                 #t))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:test-target "test"
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key inputs outputs #:allow-other-keys)
+  ;; Upstream modifies source tarballs in place, making significant changes
+  ;; long after the initial publication: <https://bugs.gnu.org/33525>.  For
+  ;; transparency, we give this "second 4.3b" release a different version
+  ;; number.
+  (let ((upstream-version "4.3e"))
+    (package
+      (name "bigloo")
+      (version "4.3e1")
+      (source (origin
+                (method url-fetch)
+                (uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Bigloo/bigloo"
+                                    upstream-version ".tar.gz"))
+                (sha256
+                 (base32
+                  "12k1kxyn3yilba0508xh8wkrw6279gnghzqi0bs2ayf5d2wkqdj3"))
+                ;; Remove bundled libraries.
+                (modules '((guix build utils)))
+                (snippet
+                 '(begin
+                    (for-each delete-file-recursively
+                              '("gc" "gmp" "libuv"))
+                    #t))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:test-target "test"
+         #:phases
+         (modify-phases %standard-phases
+           (replace 'configure
+             (lambda* (#:key inputs outputs #:allow-other-keys)
 
-             (substitute* "configure"
-               (("^shell=.*$")
-                (string-append "shell=" (which "bash") "\n"))
-               (("`date`") "0"))
-             (substitute* "autoconf/runtest.in"
-               ((", @DATE@") ""))
-             (substitute* "autoconf/osversion"
-               (("^version.*$") "version=\"\"\n"))
-             (substitute* "comptime/Makefile"
-               (("\\$\\(LDCOMPLIBS\\)")
-                "$(LDCOMPLIBS) $(LDFLAGS)"))
+               (substitute* "configure"
+                 (("^shell=.*$")
+                  (string-append "shell=" (which "bash") "\n"))
+                 (("`date`") "0"))
+               (substitute* "autoconf/runtest.in"
+                 ((", @DATE@") ""))
+               (substitute* "autoconf/osversion"
+                 (("^version.*$") "version=\"\"\n"))
+               (substitute* "comptime/Makefile"
+                 (("\\$\\(LDCOMPLIBS\\)")
+                  "$(LDCOMPLIBS) $(LDFLAGS)"))
 
-             ;; The `configure' script doesn't understand options
-             ;; of those of Autoconf.
-             (let ((out (assoc-ref outputs "out")))
-               (invoke "./configure"
-                       (string-append "--prefix=" out)
-                       ; use system libraries
-                       "--customgc=no"
-                       "--customunistring=no"
-                       "--customlibuv=no"
-                       (string-append"--mv=" (which "mv"))
-                       (string-append "--rm=" (which "rm"))
-                       "--cflags=-fPIC"
-                       (string-append "--ldflags=-Wl,-rpath="
-                                      (assoc-ref outputs "out")
-                                      "/lib/bigloo/" ,version)
-                       (string-append "--lispdir=" out
-                                      "/share/emacs/site-lisp")
-                       "--sharedbde=yes"
-                       "--sharedcompiler=yes"
-                       "--disable-patch"))))
-         (add-after 'install 'install-emacs-modes
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (dir (string-append out "/share/emacs/site-lisp")))
-               (invoke "make" "-C" "bmacs" "all" "install"
-                       (string-append "EMACSBRAND=emacs25")
-                       (string-append "EMACSDIR=" dir))))))))
-    (inputs
-     `(("emacs" ,emacs)                      ;UDE needs the X version of Emacs
-       ("libgc" ,libgc)
-       ("libunistring" ,libunistring)
-       ("libuv" ,libuv)
-       ("openssl" ,openssl)
-       ("sqlite" ,sqlite)
+               ;; The `configure' script doesn't understand options
+               ;; of those of Autoconf.
+               (let ((out (assoc-ref outputs "out")))
+                 (invoke "./configure"
+                         (string-append "--prefix=" out)
+                                                  ; use system libraries
+                         "--customgc=no"
+                         "--customunistring=no"
+                         "--customlibuv=no"
+                         (string-append"--mv=" (which "mv"))
+                         (string-append "--rm=" (which "rm"))
+                         "--cflags=-fPIC"
+                         (string-append "--ldflags=-Wl,-rpath="
+                                        (assoc-ref outputs "out")
+                                        "/lib/bigloo/" ,upstream-version)
+                         (string-append "--lispdir=" out
+                                        "/share/emacs/site-lisp")
+                         "--sharedbde=yes"
+                         "--sharedcompiler=yes"
+                         "--disable-patch"))))
+           (add-after 'install 'install-emacs-modes
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (dir (string-append out "/share/emacs/site-lisp")))
+                 (invoke "make" "-C" "bmacs" "all" "install"
+                         (string-append "EMACSBRAND=emacs25")
+                         (string-append "EMACSDIR=" dir))))))))
+      (inputs
+       `(("emacs" ,emacs)                     ;UDE needs the X version of Emacs
+         ("libgc" ,libgc)
+         ("libunistring" ,libunistring)
+         ("libuv" ,libuv)
+         ("openssl" ,openssl)
+         ("sqlite" ,sqlite)
 
-       ;; Optional APIs for which Bigloo has bindings.
-       ("avahi" ,avahi)
-       ("libphidget" ,libphidget)
-       ("pcre" ,pcre)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (propagated-inputs
-     `(("gmp" ,gmp)))                             ; bigloo.h refers to gmp.h
-    (home-page "http://www-sop.inria.fr/indes/fp/Bigloo/")
-    (synopsis "Efficient Scheme compiler")
-    (description
-     "Bigloo is a Scheme implementation devoted to one goal: enabling
-Scheme based programming style where C(++) is usually
-required.  Bigloo attempts to make Scheme practical by offering
-features usually presented by traditional programming languages
-but not offered by Scheme and functional programming.  Bigloo
-compiles Scheme modules.  It delivers small and fast stand alone
-binary executables.  Bigloo enables full connections between
-Scheme and C programs and between Scheme and Java programs.")
-    (license gpl2+)))
+         ;; Optional APIs for which Bigloo has bindings.
+         ("avahi" ,avahi)
+         ("libphidget" ,libphidget)
+         ("pcre" ,pcre)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)))
+      (propagated-inputs
+       `(("gmp" ,gmp)))                            ; bigloo.h refers to gmp.h
+      (home-page "http://www-sop.inria.fr/indes/fp/Bigloo/")
+      (synopsis "Efficient Scheme compiler")
+      (description
+       "Bigloo is a Scheme implementation devoted to one goal: enabling Scheme
+based programming style where C(++) is usually required.  Bigloo attempts to
+make Scheme practical by offering features usually presented by traditional
+programming languages but not offered by Scheme and functional programming.
+Bigloo compiles Scheme modules.  It delivers small and fast stand alone binary
+executables.  Bigloo enables full connections between Scheme and C programs
+and between Scheme and Java programs.")
+      (license gpl2+))))
 
 (define-public hop
   (package
     (name "hop")
-    (version "3.1.0-pre2")
+    (version "3.2.0-pre1")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Hop/hop-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0bvq79vxcpgwydwi923cxb5w9isx2x8r3d0xndbdhacmmsw1m811"))))
+               "0jf418d0s9imv98s6qrpjxr1mdaxr37knh5qyfl5y4a9cc41mlg5"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -319,8 +340,12 @@ Scheme and C programs and between Scheme and Java programs.")
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
+               (substitute* '("tools/Makefile"
+                              "test/hopjs/TEST.in")
+                 (("/bin/rm") (which "rm")))
                (invoke "./configure"
                        (string-append "--prefix=" out)
+                       "--hostcc=gcc"
                        (string-append "--blflags="
                                       ;; user flags completely override useful
                                       ;; default flags, so repeat them here.
@@ -348,14 +373,14 @@ mashups, office (web agendas, mail clients, ...), etc.")
 (define-public chicken
   (package
     (name "chicken")
-    (version "4.13.0")
+    (version "5.0.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://code.call-cc.org/releases/"
                                   version "/chicken-" version ".tar.gz"))
               (sha256
                (base32
-                "0hvckhi5gfny3mlva6d7y9pmx7cbwvq0r7mk11k3sdiik9hlkmdd"))))
+                "15b5yrzfa8aimzba79x7v6y282f898rxqxfxrr446sjx9jwlpfd8"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)
@@ -460,6 +485,9 @@ implementation techniques and as an expository tool.")
                (substitute* "share/pkgs/math-lib/math/private/bigfloat/mpfr.rkt"
                  (("ffi-lib libmpfr-so")
                   (format #f "ffi-lib \"~a\"" (find-so "libmpfr"))))
+               (substitute* "share/pkgs/readline-lib/readline/rktrl.rkt"
+                 (("\\(getenv \"PLT_READLINE_LIB\"\\)")
+                  (format #f "\"~a\"" (find-so "libedit"))))
                (for-each
                 (lambda (x) (apply patch-ffi-libs x))
                 '(("share/pkgs/draw-lib/racket/draw/unsafe/cairo-lib.rkt"
@@ -487,9 +515,7 @@ implementation techniques and as an expository tool.")
                   ("share/pkgs/gui-lib/mred/private/wx/gtk/gl-context.rkt"
                    ("libGL"))
                   ("share/pkgs/sgl/gl.rkt"
-                   ("libGL" "libGLU"))
-                  ("share/pkgs/readline-lib/readline/rktrl.rkt"
-                   ("libedit")))))
+                   ("libGL" "libGLU")))))
              (chdir "src")
              #t))
          (add-after 'unpack 'patch-/bin/sh
@@ -531,7 +557,7 @@ of libraries.")
 (define-public gambit-c
   (package
     (name "gambit-c")
-    (version "4.8.9")
+    (version "4.9.1")
     (source
      (origin
        (method url-fetch)
@@ -541,25 +567,14 @@ of libraries.")
              (string-map (lambda (c) (if (char=? c #\.) #\_ c)) version)
              ".tgz"))
        (sha256
-        (base32 "16sg1s8myzxqpimj5ry6lfza0qfs157zj28bvmxwwgy89jd9m5v7"))))
+        (base32 "14x9xa0yh7187alzw2m937jnh4csj0dyywi3va8bhi7aaw4p5qai"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
        ;; According to the ./configure script, this makes the build slower and
        ;; use >= 1 GB memory, but makes Gambit much faster.
-       '("--enable-single-host")
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'fix-tests
-           (lambda _
-             (substitute* '("tests/makefile")
-               ;; '-:' is how run-time options are set.  'tl' sets some terminal
-               ;; option, which makes it fail in our build environment.  It
-               ;; recommends using 'd-' as a solution, which sets the REPL
-               ;; interaction channel to stdin/stdout.
-               (("gsi -:tl") "gsi -:d-,tl"))
-             #t)))))
-    (home-page "http://www.iro.umontreal.ca/~gambit/")
+       '("--enable-single-host")))
+    (home-page "http://dynamo.iro.umontreal.ca/wiki/index.php/Main_Page")
     (synopsis "Efficient Scheme interpreter and compiler")
     (description
      "Gambit consists of two main programs: gsi, the Gambit Scheme
@@ -1105,3 +1120,127 @@ in-lining, unboxing, and flow-directed program-specific and
 program-point-specific low-level representation selection and code
 generation.")
       (license gpl2+))))
+
+(define-public femtolisp
+  (let ((commit "68c5b1225572ecf2c52baf62f928063e5a30511b")
+        (revision "1"))
+    (package
+      (name "femtolisp")
+      (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/JeffBezanson/femtolisp.git")
+                      (commit commit)))
+                (file-name (string-append name "-" version "-checkout"))
+                (sha256
+                 (base32
+                  "04rnwllxnl86zw8c6pwxznn49bvkvh0f1lfliy085vjzvlq3rgja"))))
+      ;; See "utils.h" for supported systems. Upstream bug:
+      ;; https://github.com/JeffBezanson/femtolisp/issues/25
+      (supported-systems
+       (fold delete %supported-systems
+             '("armhf-linux" "mips64el-linux" "aarch64-linux")))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:make-flags '("CC=gcc" "release")
+         #:test-target "test"
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure) ; No configure script
+           (replace 'install ; Makefile has no 'install phase
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let* ((out (assoc-ref outputs "out"))
+                     (bin (string-append out "/bin")))
+                (install-file "flisp" bin)
+                #t)))
+           ;; The flisp binary is now available, run bootstrap to
+           ;; generate flisp.boot and afterwards runs make test.
+           (add-after 'install 'bootstrap-gen-and-test
+             (lambda* (#:key outputs #:allow-other-keys)
+              (let* ((out (assoc-ref outputs "out"))
+                     (bin (string-append out "/bin")))
+                (and
+                 (zero? (system* "./bootstrap.sh"))
+                 (install-file "flisp.boot" bin))))))))
+      (synopsis "Scheme-like lisp implementation")
+      (description
+       "@code{femtolisp} is a scheme-like lisp implementation with a
+simple, elegant Scheme dialect.  It is a lisp-1 with lexical scope.
+The core is 12 builtin special forms and 33 builtin functions.")
+      (home-page "https://github.com/JeffBezanson/femtolisp")
+      (license bsd-3))))
+
+(define-public gauche
+  (package
+    (name "gauche")
+    (version "0.9.7")
+    (home-page "http://practical-scheme.net/gauche/index.html")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://sourceforge/gauche/Gauche/Gauche-"
+             version ".tgz"))
+       (sha256
+        (base32
+         "181nycikma0rwrb1h6mi3kys11f8628pq8g5r3fg5hiz5sabscrd"))
+       (modules '((guix build utils)))
+       (snippet '(begin
+                   ;; Remove libatomic-ops
+                   (delete-file-recursively "gc/libatomic_ops")
+                   #t))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libatomic-ops" ,libatomic-ops)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("texinfo" ,texinfo)
+       ("openssl" ,openssl) ; needed for tests
+       ("pkg-config" ,pkg-config))) ; needed to find external libatomic-ops
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-/bin/sh
+           ;; needed only for tests
+           (lambda _
+             (substitute* '("configure"
+                            "test/www.scm"
+                            "ext/tls/test.scm"
+                            "gc/configure"
+                            "lib/gauche/configure.scm"
+                            "lib/gauche/package/util.scm"
+                            "lib/gauche/process.scm")
+               (("/bin/sh") (which "sh")))
+             #t))
+         (add-after 'build 'build-doc
+           (lambda _
+             (with-directory-excursion "doc"
+               (invoke "make" "info"))
+             #t))
+         (add-before 'check 'patch-normalize-test
+           ;; neutralize sys-normalize-pathname test as it relies on
+           ;; the home directory; (setenv "HOME" xx) isn't enough)
+           (lambda _
+             (substitute* "test/system.scm"
+               (("~/abc") "//abc"))
+             #t))
+         (add-before 'check 'patch-network-tests
+           ;; remove net checks
+           (lambda _
+             (substitute* "ext/Makefile"
+               (("binary net termios") "binary termios"))
+             #t))
+         (add-after 'install 'install-docs
+           (lambda _
+             (with-directory-excursion "doc"
+               (invoke "make" "install"))
+             #t)))))
+    (synopsis "Scheme scripting engine")
+    (description "Gauche is a R7RS Scheme scripting engine aiming at being a
+handy tool that helps programmers and system administrators to write small to
+large scripts quickly.  Quick startup, built-in system interface, native
+multilingual support are some of the goals.  Gauche comes with a package
+manager/installer @code{gauche-package} which can download, compile, install
+and list gauche extension packages.")
+    (license bsd-3)))