gnu: msmtp: Update to 1.8.10.
[jackhill/guix/guix.git] / gnu / packages / syndication.scm
index bfcefb7..5bc3d19 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -84,27 +84,20 @@ interface that might look familiar to @command{mutt} or @command{slrn} users.
 
 Newsboat supports OPML import/exports, HTML rendering, podcasts (with
 @command{podboat}), off-line reading, searching and storing articles to your
-file system, and many more features.
-
-It started life as a fork of the currently unmaintained Newsbeuter.")
+file system, and many more features.")
     (license (list license:gpl2+        ; filter/*
                    license:expat))))    ; everything else
 
-(define-public newsbeuter
-  ;; Newsbeuter is unmaintained with multiple CVEs, and was forked as Newsboat.
-  (deprecated-package "newsbeuter" newsboat))
-
 (define-public rtv
   (package
     (name "rtv")
-    (version "1.26.0")
+    (version "1.27.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "rtv" version))
         (sha256
-         (base32
-          "1aamkli1mlq2vxixlva790y0l0cbvbkz07lknajin0841sdq0411"))))
+         (base32 "0hvw426y09l3yzwv2zkb9hifpfbg9wd1gg0y3z3pxcli6n3ii2wl"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -137,3 +130,42 @@ It started life as a fork of the currently unmaintained Newsbeuter.")
      "RTV provides a text-based interface to view and interact with Reddit.")
     (license (list license:expat
                    license:gpl3+)))) ; rtv/packages/praw
+
+(define-public tuir
+  (package
+    (name "tuir")
+    (version "1.28.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "tuir" version))
+        (sha256
+         (base32
+          "1gpyjrl7jdfjq30m32nzh59ajv91gq19l93jjri2wsv5yrf90hdr"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest"))))))
+    (inputs
+     `(("python-beautifulsoup4" ,python-beautifulsoup4)
+       ("python-decorator" ,python-decorator)
+       ("python-kitchen" ,python-kitchen)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-coveralls" ,python-coveralls)
+       ("python-mock" ,python-mock)
+       ("python-pylint" ,python-pylint)
+       ("python-pytest" ,python-pytest)
+       ("python-vcrpy" ,python-vcrpy)))
+    (home-page "https://gitlab.com/ajak/tuir")
+    (synopsis "Terminal viewer for Reddit (Terminal UI for Reddit)")
+    (description
+     "Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
+    (license (list license:expat
+                   license:gpl3+))))    ; tuir/packages/praw