Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / gnutls.scm
index 77eb30c..ce13d81 100644 (file)
   #:use-module (guix build-system gnu)
   #:use-module ((gnu packages compression)
                 #:renamer (symbol-prefix-proc 'guix:))
+  #:use-module (gnu packages)
   #:use-module (gnu packages nettle)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages perl)
-  #:use-module (gnu packages which))
+  #:use-module (gnu packages which)
+  #:use-module (gnu packages pkg-config))
 
 (define-public libtasn1
   (package
     (home-page "http://www.gnu.org/software/libtasn1/")
     (synopsis "ASN.1 library")
     (description
-     "Libtasn1 is the ASN.1 library used by GnuTLS, GNU Shishi and some
-other packages.  The goal of this implementation is to be highly
-portable, and only require an ANSI C89 platform.")
+     "Libtasn1 is a library implementing the ASN.1 notation.  It is used for
+transmitting machine-neutral encodings of data objects in computer
+networking, allowing for formal validation of data according to some
+specifications.")
     (license lgpl2.0+)))
 
 (define-public gnutls
   (package
     (name "gnutls")
-    (version "3.1.9.1")
+    (version "3.2.4")
     (source (origin
              (method url-fetch)
              (uri
               ;; Note: Releases are no longer on ftp.gnu.org since the
               ;; schism (after version 3.1.5).
-              (string-append "mirror://gnupg/gnutls/v3.1/gnutls-"
+              (string-append "mirror://gnupg/gnutls/v3.2/gnutls-"
                              version ".tar.xz"))
              (sha256
               (base32
-               "0gkwhz7sypfy39jfj2yzrngbxq5j9l9smqc89mqlqsh25spc8009"))))
+               "0zvhzy87v9dfxfvmg1pl951kw55rp647cqdza8942fxq7spp158i"))))
     (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (inputs
      `(("guile" ,guile-2.0)
        ("zlib" ,guix:zlib)
@@ -75,15 +80,8 @@ portable, and only require an ANSI C89 platform.")
     (home-page "http://www.gnu.org/software/gnutls/")
     (synopsis "Transport layer security library")
     (description
-     "GnuTLS is a project that aims to develop a library which provides
-a secure layer, over a reliable transport layer. Currently the GnuTLS
-library implements the proposed standards by the IETF's TLS working
-group.
-
-Quoting from the TLS protocol specification:
-
-\"The TLS protocol provides communications privacy over the
-Internet. The protocol allows client/server applications to communicate
-in a way that is designed to prevent eavesdropping, tampering, or
-message forgery.\"")
+     "GnuTLS is a secure communications library implementing the SSL, TLS
+and DTLS protocols.  It is provided in the form of a C library to the
+protocols, as well as to parse and write X.5009, PKCS 12, OpenPGP and other
+required structures.")
     (license lgpl2.1+)))