gnu: Avoid circular dependencies by Perl license.
[jackhill/guix/guix.git] / gnu / packages / bioinformatics.scm
index 02485c6..c80084f 100644 (file)
@@ -721,7 +721,7 @@ objects are made from the Sequence objects, Sequence objects have access to
 Annotation and SeqFeature objects and databases, Blast objects can be
 converted to Alignment objects, and so on.  This means that the objects
 provide a coordinated and extensible framework to do computational biology.")
-      (license (package-license perl)))))
+      (license license:perl-license))))
 
 (define-public python-biopython
   (package
@@ -5271,7 +5271,7 @@ Cuffdiff or Ballgown programs.")
 (define-public vcftools
   (package
     (name "vcftools")
-    (version "0.1.14")
+    (version "0.1.15")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -5279,7 +5279,7 @@ Cuffdiff or Ballgown programs.")
                     version "/vcftools-" version ".tar.gz"))
               (sha256
                (base32
-                "10l5c07z9p4i9pr4gl54b2c9h6ndhqlbq1rashg2zcgwkbfrkmvn"))))
+                "1qw30c45wihgy632rbz4rh3njnwj4msj46l1rsgdhyg6bgypmr1i"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; no "check" target
@@ -6340,7 +6340,11 @@ possible.")
     (version "0.99.0")
     (source (origin
               (method url-fetch)
-              (uri (bioconductor-uri "GenomeInfoDbData" version))
+              ;; We cannot use bioconductor-uri here because this tarball is
+              ;; located under "data/annotation/" instead of "bioc/".
+              (uri (string-append "https://bioconductor.org/packages/release/"
+                                  "data/annotation/src/contrib/GenomeInfoDbData_"
+                                  version ".tar.gz"))
               (sha256
                (base32
                 "120qvhb0pvkzd65lsgja62vyrgc37si6fh68q4cg4w5x9f04jw25"))))
@@ -8676,14 +8680,14 @@ of mass spectrometry based proteomics data.")
 (define-public r-msnid
   (package
     (name "r-msnid")
-    (version "1.8.0")
+    (version "1.10.0")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "MSnID" version))
        (sha256
         (base32
-         "0fkk3za39cxi0jyxmagmycjdslr2xf6vg3ylz14jyffqi0blw9d5"))))
+         "0pjwargi5lif8q53fd43ql67p3yk9w10jychafd9qgbaw5k3f68k"))))
     (properties `((upstream-name . "MSnID")))
     (build-system r-build-system)
     (propagated-inputs