gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / multiprecision.scm
index 5e0dee0..377d922 100644 (file)
@@ -27,7 +27,7 @@
 (define-public gmp
   (package
    (name "gmp")
-   (version "5.1.1")
+   (version "6.0.0a")
    (source (origin
             (method url-fetch)
             (uri
                             version ".tar.xz"))
             (sha256
              (base32
-              "1hili06lcf0clg5qfvz7knm6pmj6ab54yhsvskp1mdny5xw4vmjb"))))
+              "0r5pp27cy7ch3dg5v0rsny8bib1zfvrza6027g2mp5f6v8pd6mli"))))
    (build-system gnu-build-system)
    (native-inputs `(("m4" ,m4)))
+   (outputs '("out" "debug"))
    (arguments `(#:configure-flags
                 '(;; Build a "fat binary", with routines for several
                   ;; sub-architectures.
                   "--enable-fat"
                   "--enable-cxx")))
-   (synopsis "GMP, the GNU multiple precision arithmetic library")
+   (synopsis "Multiple-precision arithmetic library")
    (description
-    "GMP is a free library for arbitrary precision arithmetic, operating on
-signed integers, rational numbers, and floating point numbers.  There is no
-practical limit to the precision except the ones implied by the available
-memory in the machine GMP runs on.  GMP has a rich set of functions, and the
-functions have a regular interface.
-
-The main target applications for GMP are cryptography applications and
-research, Internet security applications, algebra systems, computational
-algebra research, etc.
-
-GMP is carefully designed to be as fast as possible, both for small operands
-and for huge operands.  The speed is achieved by using fullwords as the basic
-arithmetic type, by using fast algorithms, with highly optimised assembly
-code for the most common inner loops for a lot of CPUs, and by a general
-emphasis on speed.
-
-GMP is faster than any other bignum library.  The advantage for GMP increases
-with the operand sizes for many operations, since GMP uses asymptotically
-faster algorithms.")
+    "GMP is a library for arbitrary precision arithmetic, operating on
+signed integers, rational numbers and floating point numbers.  The precision
+is only limited by the available memory.  The library is highly optimized,
+with a design focus on execution speed.  It is aimed at use in, for example,
+cryptography and computational algebra.")
    (license lgpl3+)
    (home-page "http://gmplib.org/")))
 
 (define-public mpfr
   (package
    (name "mpfr")
-   (version "3.1.1")
+   (version "3.1.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/mpfr/mpfr-" version
                                 ".tar.xz"))
             (sha256 (base32
-                     "0ym1ylcq803n52qrggxqmkz66gbn8ncc3ybawal31v5y5p1srma9"))))
+                     "0fs501qi8l523gs3cpy4jjcnvwxggyfbklcys80wq236xx3hz79r"))))
    (build-system gnu-build-system)
+   (outputs '("out" "debug"))
    (propagated-inputs `(("gmp" ,gmp)))            ; <mpfr.h> refers to <gmp.h>
-   (synopsis "GNU MPFR, a library for multiple-precision floating-point
-arithmetic")
+   (synopsis "C library for arbitrary precision floating-point arithmetic")
    (description
-    "The GNU MPFR library is a C library for multiple-precision
-floating-point computations with correct rounding.  MPFR is based on the GMP
-multiple-precision library.
-
-The main goal of MPFR is to provide a library for multiple-precision
-floating-point computation which is both efficient and has a well-defined
-semantics.  It copies the good ideas from the ANSI/IEEE-754 standard for
-double-precision floating-point arithmetic (53-bit mantissa).")
+    "GNU MPFR is a C library for performing multiple-precision,
+floating-point computations with correct rounding.")
    (license lgpl3+)
    (home-page "http://www.mpfr.org/")))
 
 (define-public mpc
   (package
    (name "mpc")
-   (version "1.0.1")
+   (version "1.0.2")
    (source (origin
             (method url-fetch)
             (uri (string-append
                   "mirror://gnu/mpc/mpc-" version ".tar.gz"))
             (sha256 (base32
-                     "1zq0fidp1jii2j5k5n9hmx55a6wwid33gjzhimvxq9d5zrf82npd"))))
+                     "1264h3ivldw5idph63x35dqqdzqqbxrm5vlir0xyx727i96zaqdm"))))
    (build-system gnu-build-system)
+   (outputs '("out" "debug"))
    (propagated-inputs `(("gmp" ,gmp)              ; <mpc.h> refers to both
                         ("mpfr" ,mpfr)))
-   (synopsis "GNU MPC, a library for multiprecision complex arithmetic
-with exact rounding")
+   (synopsis "C library for arbitrary precision complex arithmetic")
    (description
-    "GNU MPC is a C library for the arithmetic of complex numbers with
-arbitrarily high precision and correct rounding of the result. It extends
-the principles of the IEEE-754 standard for fixed precision real floating
-point numbers to complex numbers, providing well-defined semantics for
-every operation. At the same time, speed of operation at high precision
-is a major design goal. The library is built upon and follows the same
-principles as GNU MPFR.")
+    "GNU MPC is a C library for performing arithmetic on complex numbers.
+It supports arbitrarily high precision and it correctly rounds the results.")
    (license lgpl3+)
    (home-page "http://mpc.multiprecision.org/")))