gnu: r-go-db: Update to 3.5.0.
[jackhill/guix/guix.git] / gnu / packages / m4.scm
index 17ca7c8..32e7c2a 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public m4
   (package
    (name "m4")
-   (version "1.4.17")
+   (version "1.4.18")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/m4/m4-"
-                                version ".tar.bz2"))
+                                version ".tar.xz"))
             (sha256
              (base32
-              "0w0da1chh12mczxa5lnwzjk9czi3dq6gnnndbpa6w4rj76b1yklf"))))
+              "01sfjd5a4waqw83bibvmn522g69qfqvwig9i2qlgy154l1nfihgj"))))
    (build-system gnu-build-system)
    (arguments
-    ;; XXX: Disable tests on those platforms with know issues.
-    `(#:tests? ,(not (member (%current-system)
-                             '("x86_64-darwin"
-                               "i686-cygwin"
-                               "i686-sunos")))
-      #:patches (list (assoc-ref %build-inputs
-                                 "patch/readlink-EINVAL"))
+    `(;; Explicitly disable tests when cross-compiling, otherwise 'make check'
+      ;; proceeds and fails, unsurprisingly.
+      #:tests? ,(not (%current-target-system))
+
       #:phases (alist-cons-before
                 'check 'pre-check
                 (lambda* (#:key inputs #:allow-other-keys)
                     (substitute* (find-files "tests"
                                              "posix_spawn")
                       (("/bin/sh")
-                       (format #f "~a/bin/bash" bash)))))
+                       (format #f "~a/bin/sh" bash)))))
                 %standard-phases)))
-   (inputs `(("patch/readlink-EINVAL"
-              ,(search-patch "m4-readlink-EINVAL.patch"))))
    (synopsis "Macro processor")
    (description
-    "GNU M4 is an implementation of the traditional Unix macro processor.  It
-is mostly SVR4 compatible although it has some extensions (for example,
-handling more than 9 positional parameters to macros).  GNU M4 also has
-built-in functions for including files, running shell commands, doing
-arithmetic, etc.
-
-GNU M4 is a macro processor in the sense that it copies its input to the
-output expanding macros as it goes.  Macros are either builtin or
-user-defined and can take any number of arguments.  Besides just doing macro
-expansion, m4 has builtin functions for including named files, running UNIX
-commands, doing integer arithmetic, manipulating text in various ways,
-recursion etc...  m4 can be used either as a front-end to a compiler or as a
-macro processor in its own right.")
+    "GNU M4 is an implementation of the M4 macro language, which features
+some extensions over other implementations, some of which are required by GNU
+Autoconf.  It is used as a macro processor, which means it processes text,
+expanding macros as it encounters them.  It also has some built-in functions,
+for example to run shell commands or to do arithmetic.")
    (license gpl3+)
-   (home-page "http://www.gnu.org/software/m4/")))
+   (home-page "https://www.gnu.org/software/m4/")))