gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / valgrind.scm
index 6c06b24..75e8529 100644 (file)
@@ -2,7 +2,7 @@
 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 (define-public valgrind
   (package
     (name "valgrind")
-    (version "3.13.0")
+    (version "3.15.0")
     (source (origin
               (method url-fetch)
-             (uri (string-append "ftp://sourceware.org/pub/valgrind/valgrind-"
-                                 version ".tar.bz2"))
-             (sha256
-              (base32
-               "0fqc3684grrbxwsic1rc5ryxzxmigzjx9p5vf3lxa37h0gpq0rnp"))
-             (patches (search-patches "valgrind-enable-arm.patch"
-                                      "valgrind-glibc-compat.patch"))))
+              (uri (list (string-append "https://sourceware.org/pub/valgrind"
+                                        "/valgrind-" version ".tar.bz2")
+                         (string-append "ftp://sourceware.org/pub/valgrind"
+                                        "/valgrind-" version ".tar.bz2")))
+              (sha256
+               (base32
+                "1ccawxrni8brcvwhygy12iprkvz409hbr9xkk1bd03gnm2fplz21"))
+              (patches (search-patches "valgrind-enable-arm.patch"))))
     (build-system gnu-build-system)
     (outputs '("doc"                              ;16 MB
                "out"))
     (arguments
-     '(#:phases
+     `(,@(if (string-prefix? "powerpc" (or (%current-target-system)
+                                           (%current-system)))
+           `(#:make-flags '("CFLAGS+=-maltivec"))
+           '())
+       #:phases
        (modify-phases %standard-phases
          (add-after 'install 'patch-suppression-files
            (lambda* (#:key outputs #:allow-other-keys)
      `(("gdb" ,gdb)))
     (native-inputs
      `(("perl" ,perl)))
-    (home-page "http://www.valgrind.org/")
+    (home-page "https://www.valgrind.org/")
     (synopsis "Debugging and profiling tool suite")
     (description
      "Valgrind is an instrumentation framework for building dynamic analysis
 tools.  There are Valgrind tools that can automatically detect many memory
 management and threading bugs, and profile your programs in detail.  You can
 also use Valgrind to build new tools.")
-    (license gpl2+)
-
-    ;; Building VEX on mips64el-linux fails with "opcode not supported on this
-    ;; processor: mips3".
-    (supported-systems (delete "mips64el-linux" %supported-systems))))
+    (license gpl2+)))