gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / wdiff.scm
index 06a44a9..20fc0bc 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,7 +24,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages screen)
-  #:use-module (gnu packages which))
+  #:use-module (gnu packages base))
 
 (define-public wdiff
   (package
         "0sxgg0ms5lhi4aqqvz1rj4s77yi9wymfm3l3gbjfd1qchy66kzrl"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (alist-cons-before
-                 'check 'fix-sh
-                 (lambda _
-                   (substitute* "tests/testsuite"
-                     (("#! /bin/sh")
-                      (string-append "#!" (which "sh")))))
-                 %standard-phases)))
-    (inputs `(("screen" ,screen)
-              ("which" ,which)
-
-              ;; For some reason wdiff.info gets rebuilt.
-              ("texinfo" ,texinfo)))
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'fix-sh
+                    (lambda _
+                      (substitute* "tests/testsuite"
+                        (("#! /bin/sh")
+                         (string-append "#!" (which "sh")))))))))
+    (native-inputs
+     `(("which" ,which)
+       ;; For some reason wdiff.info gets rebuilt.
+       ("texinfo" ,texinfo)))
     (home-page "https://www.gnu.org/software/wdiff/")
     (synopsis "Word difference finder")
     (description