gnu: Add clutter.
[jackhill/guix/guix.git] / gnu / packages / geeqie.scm
index 54b3a05..ff45bda 100644 (file)
 (define-module (gnu packages geeqie)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'l:))
+  #:use-module ((guix licenses) #:prefix l:)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
-  #:use-module (gnu packages libpng)
+  #:use-module (gnu packages image)
   #:use-module ((gnu packages ghostscript)
                 #:select (lcms))
   #:use-module (gnu packages compression)
@@ -50,7 +49,7 @@
     (synopsis "Library and command-line utility to manage image metadata")
     (description
      "Exiv2 is a C++ library and a command line utility to manage image
-metadata. It provides fast and easy read and write access to the Exif, IPTC
+metadata.  It provides fast and easy read and write access to the Exif, IPTC
 and XMP metadata of images in various formats.")
 
     ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
@@ -72,11 +71,12 @@ and XMP metadata of images in various formats.")
     (build-system gnu-build-system)
     (inputs
      `(;; ("libchamplain" ,libchamplain)
-       ("intltool" ,intltool)
        ("lcms" ,lcms)
        ("exiv2" ,exiv2)
        ("libpng" ,libpng)
-       ("gtk+" ,gtk+)
+       ("gtk+" ,gtk+-2)))
+    (native-inputs
+     `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
     (home-page "http://geeqie.sourceforge.net")
     (synopsis "Lightweight GTK+ based image viewer")