gnu: Add rust-crypto-hash-0.3.
[jackhill/guix/guix.git] / gnu / packages / protobuf.scm
index 4d7a64a..857adf1 100644 (file)
@@ -6,6 +6,7 @@
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -39,6 +40,7 @@
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages ruby))
@@ -82,7 +84,7 @@ data in motion, or as a file format for data at rest.")
 (define-public protobuf
   (package
     (name "protobuf")
-    (version "3.12.3")
+    (version "3.14.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/google/protobuf/releases/"
@@ -90,7 +92,7 @@ data in motion, or as a file format for data at rest.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0s29dj8l9j6jk04im3ivcji1x9jm42fwjmwcmli0smz0m337xyaf"))))
+                "0nan2wkkwkcx3qyx0cf5vfzjcjhr5qgh4jfx6v2lwpf5q03mmv2h"))))
     (build-system gnu-build-system)
     (inputs `(("zlib" ,zlib)))
     (outputs (list "out"
@@ -121,7 +123,8 @@ internal RPC protocols and file formats.")
 
 ;; Tensorflow requires version 3.6 specifically.
 (define-public protobuf-3.6
-  (package/inherit protobuf
+  (package
+    (inherit protobuf)
     (version "3.6.1")
     (source (origin
               (method url-fetch)
@@ -134,8 +137,8 @@ internal RPC protocols and file formats.")
 
 ;; The 3.5 series are the last versions that do not require C++ 11.
 (define-public protobuf-3.5
-  (package/inherit
-   protobuf
+  (package
+    (inherit protobuf)
    (version "3.5.1")
    (source (origin
               (method url-fetch)
@@ -162,7 +165,7 @@ internal RPC protocols and file formats.")
 (define-public protobuf-c
   (package
     (name "protobuf-c")
-    (version "1.3.2")
+    (version "1.3.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/protobuf-c/protobuf-c/"
@@ -170,7 +173,7 @@ internal RPC protocols and file formats.")
                                   "/protobuf-c-" version ".tar.gz"))
               (sha256
                (base32
-                "0x4ybd9rfd878p2imz0hb8zxfd7l60vbdw7cg84dnysr9kqm3wjk"))))
+                "0y3yaanq97si7iyld06p8w20m0shpj7sf4xwzbhhvijhxw36d592"))))
     (build-system gnu-build-system)
     (inputs `(("protobuf" ,protobuf)))
     (native-inputs `(("pkg-config" ,pkg-config)))
@@ -276,7 +279,7 @@ mechanism for serializing structured data.")
     (home-page "https://pypi.org/project/pure-protobuf/")
     (synopsis "Protobuf implementation using dataclasses")
     (description
-     "@code{python-pure-protobuf} allows to take advantage of the standard
+     "@code{python-pure-protobuf} takes advantage of the standard
 dataclasses module to define message types.  Protocol buffers are a
 language-neutral, platform-neutral extensible mechanism for serializing
 structured data.")
@@ -287,7 +290,8 @@ structured data.")
 
 ;; For tensorflow.
 (define-public python-protobuf-3.6
-  (package/inherit python-protobuf
+  (package
+    (inherit python-protobuf)
     (name "python-protobuf")
     (version (package-version protobuf-3.6) )
     (source
@@ -392,7 +396,8 @@ source files.")
     (propagated-inputs
      `(("ruby-activesupport" ,ruby-activesupport)
        ("ruby-middleware" ,ruby-middleware)
-       ("ruby-thor" ,ruby-thor)))
+       ("ruby-thor" ,ruby-thor)
+       ("ruby-thread-safe" ,ruby-thread-safe)))
     (home-page "https://github.com/ruby-protobuf/protobuf")
     (synopsis "Implementation of Google's Protocol Buffers in Ruby")
     (description "Protobuf is an implementation of Google's Protocol Buffers