gnu: gtkmm: Use the for-test xorg variant for tests.
[jackhill/guix/guix.git] / gnu / packages / sdcc.scm
index c3d4bce..6d05470 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30,7 +31,7 @@
 (define-public sdcc
   (package
     (name "sdcc")
-    (version "3.6.0")
+    (version "3.7.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -38,7 +39,7 @@
                     "/" version "/sdcc-src-" version ".tar.bz2"))
               (sha256
                (base32
-                "0x53gh5yrrfjvlnkk29mjn8hq4v52alrsf7c8nsyzzq13sqwwpg8"))))
+                "13llvx0j3v5qa7qd4fh7nix4j3alpd3ccprxvx163c4q8q4lfkc5"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
@@ -49,7 +50,7 @@
     (arguments
      `(;; gputils is required for PIC ports
        #:configure-flags
-       '("--disable-pic14-port" "--disable-pic16-port")
+       '("--disable-pic14-port" "--disable-pic16-port" "--enable-ucsim")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-makefile
              #t)))))
     (home-page "http://sdcc.sourceforge.net")
     (synopsis "Small devices C compiler")
-    (description "SDCC is a retargettable, optimizing Standard C compiler suite
-that targets the Intel MCS51 based microprocessors (8031, 8032, 8051, 8052, ...),
+    (description "SDCC is a retargetable, optimizing Standard C compiler suite
+that targets the Intel MCS51-based microprocessors (8031, 8032, 8051, 8052, ...),
 Maxim (formerly Dallas) DS80C390 variants, Freescale (formerly Motorola)
-HC08 based (hc08, s08), Zilog Z80 based MCUs (z80, z180, gbz80, Rabbit
+HC08-based (hc08, s08), Zilog Z80-based MCUs (z80, z180, gbz80, Rabbit
 2000/3000, Rabbit 3000A, TLCS-90) and STMicroelectronics STM8.
 Work is in progress on supporting the Microchip PIC16 and PIC18 targets.
 It can be retargeted for other microprocessors.")