gnu: facter: Update to 4.0.34.
[jackhill/guix/guix.git] / gnu / packages / sawfish.scm
index 54b72ff..26d8eba 100644 (file)
@@ -1,5 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Benjamin Slade <slade@jnanam.net>
+;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,7 +25,8 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
-  #:use-module (gnu packages databases)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages dbm)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages libffi)
 (define-public librep
   (package
     (name "librep")
-    (version "0.92.5")
+    (version "0.92.7")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://download.tuxfamily.org/" name "/"
-                                  name "_" version ".tar.xz"))
+              (uri (string-append "http://download.tuxfamily.org/librep/"
+                                  "librep_" version ".tar.xz"))
               (sha256
                (base32
-                "0zsy5gi8kvz5vq41y5rzm6lfi3dpiwbg4diwb6d30qfi72mrpni2"))))
+                "1bmcjl1x1rdh514q9z3hzyjmjmwwwkziipjpjsl301bwmiwrd8a8"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("makeinfo"   ,texinfo)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+
+       ("autoconf" ,autoconf-wrapper)
+       ("automake" ,automake)
+       ("libtool"  ,libtool)))
     (inputs
      `(("gdbm"     ,gdbm)
        ("gmp"      ,gmp)
@@ -57,7 +65,7 @@
      (list (search-path-specification
             (variable "REP_DL_LOAD_PATH")
             (files '("lib/rep")))))
-    (home-page "http://sawfish.wikia.com/wiki/Librep")
+    (home-page "https://sawfish.fandom.com/wiki/Librep")
     (synopsis "Lisp system for sawfish")
     (description
      "Librep is a dialect of Lisp, designed to be used both as an extension
@@ -71,29 +79,43 @@ implementing both small and large scale systems.")
 (define-public rep-gtk
   (package
     (name "rep-gtk")
-    (version "0.90.8.2")
+    (version "0.90.8.3")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://download.tuxfamily.org/librep/"
+              (uri (string-append "https://download.tuxfamily.org/librep/"
                                   name "/" name "_" version ".tar.xz"))
               (sha256
                (base32
-                "0qslm2isyv22hffdpw0nh7xk8jw8cj3h5y7d40c9h5r833w7j6sz"))
+                "0hgkkywm8zczir3lqr727bn7ybgg71x9cwj1av8fykkr8pdpard9"))
               (modules '((guix build utils)))
               (snippet
-               '(substitute* "Makefile.in"
-                  (("installdir=\\$\\(repexecdir\\)")
-                   ;; Install libraries for librep to $out/lib/rep.
-                   "installdir=$(libdir)/rep")))))
+               '(begin
+                  (substitute* "Makefile.in"
+                    (("installdir=\\$\\(repexecdir\\)")
+                     ;; Install libraries for librep to $out/lib/rep.
+                     "installdir=$(libdir)/rep"))
+                  #t))))
     (build-system gnu-build-system)
-    (arguments '(#:tests? #f)) ; no tests
+    (arguments
+     `(#:tests? #f ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'bootstrap 'remove-autogen
+           (lambda _
+             ;; Remove autogen.sh so that the bootstrap phase can run
+             ;; autoreconf.
+             (delete-file "autogen.sh")
+             #t)))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
     (propagated-inputs
      ;; required by rep-gtk.pc.
      `(("gtk+"   ,gtk+-2)
        ("librep" ,librep)))
-    (home-page "http://sawfish.wikia.com/wiki/Rep-GTK")
+    (home-page "https://sawfish.fandom.com/wiki/Rep-GTK")
     (synopsis "GTK+ binding for librep")
     (description
      "Rep-GTK is a GTK+ (and GLib, GDK) binding to the librep, and one of the
@@ -103,14 +125,14 @@ backend of Sawfish.")
 (define-public sawfish
   (package
     (name "sawfish")
-    (version "1.11")
+    (version "1.12.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://download.tuxfamily.org/sawfish/"
+              (uri (string-append "https://download.tuxfamily.org/sawfish/"
                                   name "_" version ".tar.xz"))
               (sha256
                (base32
-                "0wp4m0p836a0rysbcdqb6z5hxlxqj3rgdbks3bs44rlssx0mcvyg"))
+                "1z7awzgw8d15aw17kpbj460pcxq8l2rhkaxk47w7yg9qrmg0xja4"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -121,36 +143,37 @@ backend of Sawfish.")
                      "REP_DL_LOAD_PATH=$(REP_DL_LOAD_PATH):"))
                   (substitute* "src/Makefile.in"
                     ;; Install libraries for librep to $out/lib/rep.
-                    (("\\$\\(repexecdir\\)") "$(libdir)/rep"))))))
+                    (("\\$\\(repexecdir\\)") "$(libdir)/rep"))
+                  #t))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f ; no tests
        #:phases
-       (alist-cons-before
-        'configure 'patch-exec-rep
-        (lambda _
-          (substitute* '("lisp/sawfish/cfg/main.jl.in"
-                         "scripts/sawfish-about.jl.in"
-                         "scripts/sawfish-client.jl"
-                         "scripts/sawfish-menu.jl")
-            (("exec rep") (string-append "exec " (which "rep")))))
-        (alist-cons-after
-         'install 'wrap-scripts
-         ;; Wrap scripts with REP_DL_LOAD_PATH for finding rep-gtk
-         ;; and sawfish.client.
-         (lambda* (#:key outputs #:allow-other-keys)
-           (define (wrap-script script)
-             (let ((out (assoc-ref outputs "out")))
-               (wrap-program (string-append out script)
-                             `("REP_DL_LOAD_PATH" =
-                               ,(list (getenv "REP_DL_LOAD_PATH")
-                                      (string-append out "/lib/rep"))))))
-           (for-each wrap-script
-                     (list "/bin/sawfish-about"
-                           "/bin/sawfish-client"
-                           "/bin/sawfish-config"
-                           "/lib/sawfish/sawfish-menu")))
-         %standard-phases))))
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-exec-rep
+           (lambda _
+             (substitute* '("lisp/sawfish/cfg/main.jl.in"
+                            "scripts/sawfish-about.jl.in"
+                            "scripts/sawfish-client.jl"
+                            "scripts/sawfish-menu.jl")
+               (("exec rep") (string-append "exec " (which "rep"))))
+             #t))
+         (add-after 'install 'wrap-scripts
+           ;; Wrap scripts with REP_DL_LOAD_PATH for finding rep-gtk
+           ;; and sawfish.client.
+           (lambda* (#:key outputs #:allow-other-keys)
+             (define (wrap-script script)
+               (let ((out (assoc-ref outputs "out")))
+                 (wrap-program (string-append out script)
+                   `("REP_DL_LOAD_PATH" =
+                     ,(list (getenv "REP_DL_LOAD_PATH")
+                            (string-append out "/lib/rep"))))))
+             (for-each wrap-script
+                       (list "/bin/sawfish-about"
+                             "/bin/sawfish-client"
+                             "/bin/sawfish-config"
+                             "/lib/sawfish/sawfish-menu"))
+             #t)))))
     (native-inputs
      `(("gettext"     ,gettext-minimal)
        ("makeinfo"    ,texinfo)
@@ -163,7 +186,7 @@ backend of Sawfish.")
        ("libxrandr"   ,libxrandr)
        ("libxtst"     ,libxtst)
        ("rep-gtk"     ,rep-gtk)))
-    (home-page "http://sawfish.wikia.com/wiki/Main_Page")
+    (home-page "https://sawfish.tuxfamily.org")
     (synopsis "Configurable window manager")
     (description
      "Sawfish is an extensible window manager using a Lisp-based scripting