gnu: kdenlive: Add missing dependencies.
[jackhill/guix/guix.git] / gnu / packages / regex.scm
index 1294149..cb7a08e 100644 (file)
@@ -1,8 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix utils))
 
 (define-public re2
    (package
      (name "re2")
-     (version "2018-03-01")
+     (version "2020-07-06")
+     (home-page "https://github.com/google/re2")
      (source (origin
-               (method url-fetch)
-               (uri
-                (string-append
-                 "https://github.com/google/re2/archive/"
-                 version ".tar.gz"))
-               (file-name (string-append name "-" version ".tar.gz"))
+               (method git-fetch)
+               (uri (git-reference (url home-page) (commit version)))
+               (file-name (git-file-name name version))
                (sha256
                 (base32
-                 "0y21g321a802xmxdbkfz0rkcark7ypglpb3jjqhf13m6s7lpxp2i"))))
+                 "12a9r9y7ry3hq0qf4znl9j7pn9mb5k6xp1f8nrk1sagfj1a504mq"))))
      (build-system gnu-build-system)
      (arguments
       `(#:modules ((guix build gnu-build-system)
@@ -66,7 +65,6 @@
               (delete-file (string-append (assoc-ref outputs "out")
                                           "/lib/libre2.a"))
               #t)))))
-     (home-page "https://github.com/google/re2")
      (synopsis "Fast, safe, thread-friendly regular expression engine")
      (description "RE2 is a fast, safe, thread-friendly alternative to
 backtracking regular expression engines like those used in PCRE, Perl and
@@ -93,9 +91,9 @@ Python.  It is a C++ library.")
              ;; The tests require the availability of the
              ;; 'en_US.ISO-8859-1' locale.
              (setenv "LOCPATH" (getcwd))
-             (zero? (system* "localedef" "--no-archive"
-                             "--prefix" (getcwd) "-i" "en_US"
-                             "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))))))
+             (invoke "localedef" "--no-archive"
+                     "--prefix" (getcwd) "-i" "en_US"
+                     "-f" "ISO-8859-1" "./en_US.ISO-8859-1"))))))
     (synopsis "Approximate regex matching library and agrep utility")
     (description "Superset of the POSIX regex API, enabling approximate
 matching.  Also ships a version of the agrep utility which behaves similar to