gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / conky.scm
index f0f19c5..0df6d1f 100644 (file)
@@ -1,5 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages fontutils)
-  #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages image)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages xorg))
 
 (define-public conky
   (package
     (name "conky")
-    (version "1.10.6")
+    (home-page "https://github.com/brndnmtthws/conky")
+    (version "1.11.6")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/brndnmtthws/conky/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1jk0my7z45vz9vd8958d27nkk4kvr53k7wyf6cz2x9xjc0lri02c"))))
+        (base32 "0y2g66fjqp2hdk0y1h4ijxhnv34j16gizvxpmbigwh4n6zijcm6v"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ; there are no tests
+     `(#:tests? #f                      ; there are no tests
        #:configure-flags
-       '("-DRELEASE=true"
-         ;; XXX: it checks ncurses with pkg-config.
-         ;; TODO: add 'ncurses.pc' to the ncurses package.
-         "-DBUILD_NCURSES=false")
+       (list "-DRELEASE=true"
+             "-DBUILD_PULSEAUDIO=ON")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'add-freetype-to-search-path
              #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
-             (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
-               (mkdir-p bin)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin")))
                (install-file "src/conky" bin))
              #t)))))
     (inputs
      `(("freetype" ,freetype)
-       ("ncurses" ,ncurses)
+       ("imlib2" ,imlib2)
        ("libx11" ,libx11)
        ("libxdamage" ,libxdamage)
+       ("libxext" ,libxext)
        ("libxft" ,libxft)
        ("libxinerama" ,libxinerama)
-       ("lua" ,lua)))
+       ("pulseaudio" ,pulseaudio)
+       ("lua" ,lua)
+       ("ncurses" ,ncurses)
+       ("curl" ,curl)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "https://github.com/brndnmtthws/conky")
     (synopsis "Lightweight system monitor for X")
     (description
      "Conky is a lightweight system monitor for X that displays operating