gnu: Use PACKAGE/INHERIT in more places.
[jackhill/guix/guix.git] / gnu / packages / libcanberra.scm
index 3769e3f..e263ba2 100644 (file)
@@ -1,6 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
+;;; Copyright © 2017, 2018 Nikita <nikita@n0.is>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (gnu packages)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
+  #:use-module (guix utils)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
@@ -31,7 +36,9 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages xiph))
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages xiph)
+  #:use-module ((srfi srfi-1) #:select (alist-delete)))
 
 (define-public libcanberra
   (package
@@ -62,7 +69,8 @@
       ;; his pleasure.
       (patch-flags '("-p0"))
       (patches
-       (list (search-patch "libcanberra-sound-theme-freedesktop.patch")))))
+       (search-patches "libcanberra-sound-theme-freedesktop.patch"
+                       "libcanberra-wayland-crash.patch"))))
     (build-system gnu-build-system)
     (inputs
      `(("alsa-lib" ,alsa-lib)
      `(("pkg-config" ,pkg-config)))
     (arguments
      `(#:phases
-       (alist-cons-before
-        'build 'patch-default-sounds-directory
-        (lambda* (#:key inputs #:allow-other-keys)
-          (substitute* "src/sound-theme-spec.c"
-            (("@SOUND_THEME_DIRECTORY@")
-             (string-append
-              (assoc-ref inputs "sound-theme-freedesktop")
-              "/share"))))
-        %standard-phases)))
+       (modify-phases %standard-phases
+         (add-before 'build 'patch-default-sounds-directory
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "src/sound-theme-spec.c"
+               (("@SOUND_THEME_DIRECTORY@")
+                (string-append
+                 (assoc-ref inputs "sound-theme-freedesktop")
+                 "/share")))
+             #t)))))
     (home-page "http://0pointer.de/lennart/projects/libcanberra/")
     (synopsis
      "Implementation of the XDG Sound Theme and Name Specifications")
@@ -96,13 +104,19 @@ GNOME.  It comes with several backends (ALSA, PulseAudio, OSS, GStreamer,
 null) and is designed to be portable.")
     (license lgpl2.1+)))
 
+(define-public libcanberra/gtk+-2
+  (package/inherit libcanberra
+    (name "libcanberra-gtk2")
+    (inputs `(,@(alist-delete "gtk+" (package-inputs libcanberra))
+              ("gtk+" ,gtk+-2)))))
+
 (define-public sound-theme-freedesktop
   (package
     (name "sound-theme-freedesktop")
     (version "0.8")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://people.freedesktop.org/~mccann/dist/"
+              (uri (string-append "https://people.freedesktop.org/~mccann/dist/"
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
@@ -117,4 +131,27 @@ sounds for various system events.")
     ;; The license of the various sounds is given in the 'CREDITS' file.
     (license (list cc-by-sa4.0 cc-by3.0 gpl2 gpl2+))
 
-    (home-page "http://www.freedesktop.org/wiki/Specifications/sound-theme-spec/")))
+    (home-page "https://www.freedesktop.org/wiki/Specifications/sound-theme-spec/")))
+
+(define-public python-pycanberra
+  (package
+    (name "python-pycanberra")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://ftp.n0.is/pub/releases/"
+                           "pycanberra-" version ".tar.xz"))
+       (sha256
+        (base32
+         "16jjf8fcgaprmz6jacsxrh17l1ad891fns38bxv49lg3s3mn1nj2"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ;No tests included.
+    (propagated-inputs
+     `(("libcanberra" ,libcanberra)))
+    (synopsis "Ctypes wrapper for the libcanberra API")
+    (description
+     "Pycanberra is a basic Python wrapper for libcanberra.")
+    (home-page "http://c.n0.is/ng0/pycanberra/")
+    (license lgpl2.1+)))