gnu: emacs-guix: Update to 0.3.1.
[jackhill/guix/guix.git] / gnu / packages / skribilo.scm
index e9c213c..78b4806 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages lout)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages plotutils)
   #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages ghostscript))
 
 (define-public skribilo
   (package
     (name "skribilo")
-    (version "0.9.2")
+    (version "0.9.3")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://savannah/skribilo/skribilo-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0wwi996403wzcp8s8iyc2p6w7f9v39lwmy35ysdd3wc31i5dy19q"))))
+               "04d8xa76jvlz25jnc6p1gzsplwcwcqrmi3f7ixdhddhl1chyz66y"))))
     (build-system gnu-build-system)
     (arguments
      ;; Make the modules available under the usual location.
      '(#:configure-flags (list (string-append "--with-guilemoduledir="
                                               (assoc-ref %outputs "out")
                                               "/share/guile/site/2.0"))
+
+       #:phases (alist-cons-before
+                 'configure 'pre-configure
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   ;; Make sure the 'skribilo' command gets to see
+                   ;; Guile-Reader, even if Guile-Reader is not in the search
+                   ;; path.
+                   (let ((reader (assoc-ref inputs "guile-reader")))
+                     (substitute* "src/skribilo.in"
+                       (("^exec (.*) -c" _ things)
+                        (string-append "exec " things
+                                       " -L " reader "/share/guile/site/2.0"
+                                       " -C " reader "/share/guile/site/2.0"
+                                       " -c")))))
+                 %standard-phases)
+
        #:parallel-build? #f))
-    ;; TODO: Add Ploticus.
+
+    (native-inputs `(("pkg-config" ,pkg-config)))
+
     (inputs `(("guile" ,guile-2.0)
               ("imagemagick" ,imagemagick)
               ("ghostscript" ,ghostscript)        ; for 'convert'
+              ("ploticus" ,ploticus)
               ("lout" ,lout)))
 
     ;; The 'skribilo' command needs them, and for people using Skribilo as a
     ;; library, these inputs are needed as well.
-    (propagated-inputs `(("guile-reader" ,guile-reader/guile-2.0)
+    (propagated-inputs `(("guile-reader" ,guile2.0-reader)
                          ("guile-lib" ,guile-lib)))
 
     (home-page "http://www.nongnu.org/skribilo/")
@@ -65,7 +86,7 @@ high-quality hard copies.
 
 The input document can use Skribilo's markup language to provide information
 about the document's structure, which is similar to HTML or LaTeX and does not
-require expertise. Alternatively, it can use a simpler, “markup-less” format
+require expertise.  Alternatively, it can use a simpler, “markup-less” format
 that borrows from Emacs' outline mode and from other conventions used in
 emails, Usenet and text.